Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592631 - Impossible to get any sound. hda-intel audio / Sony Vaio vpc-eb1e0e FC13beta
Summary: Impossible to get any sound. hda-intel audio / Sony Vaio vpc-eb1e0e FC13beta
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 13
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-15 20:22 UTC by asjholliday
Modified: 2010-09-14 16:07 UTC (History)
8 users (show)

Fixed In Version: 2.6.34.6-54
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-14 16:07:21 UTC


Attachments (Terms of Use)

Description asjholliday 2010-05-15 20:22:04 UTC
Description of problem: Impossible to get any sound. hda-intel audio / Sony Vaio vpc-eb1e0e, tried numerous ways of getting this working - see below


Version-Release number of selected component (if applicable):
Kernel 2.6.33.3-85.fc13.x86_64

How reproducible:
Every time

Additional info:
lspci -v
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
        Subsystem: Sony Corporation Device 9071
        Flags: bus master, fast devsel, latency 0, IRQ 31
        Memory at f6000000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

aplay-l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC269 Analog [ALC269 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI 0 [INTEL HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 7: INTEL HDMI 1 [INTEL HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I have tried:

1. modprobe snd-hda-intel (plus other modules)
2. Downloading the latest alsa drivers and installing them as per various guides on the net (extracting the drivers and typing ./configure etc
3. going to alsamixer and ensuring nothing is muted
4. Ensuring by going to Multimedia that the correct drivers are loaded and in the right order and clicking test.  Linux thinks the sound is playing but it's silence from the speakers.
5. Updating everything


I have spent 3 days trying to get this working.  I did manage to get it working following the above method in Kubuntu (albeit briefly and then couldn't get it working again, so tried Fedora).  It works fine in Windows...

Bugs like this will stop a lot of people from taking up Linux.  I am a techie and really into my techie stuff, it should take me 10 minutes to get this sort of thing working, not me giving up after 3 days of rebuilds

I am about to use Windows now until I can find a solution to get the sound working in any version of Linux.  It's a real shame and despite Linux coming so far, the sound just simply does not work at all.   It didn't work on FC12 either so I was hoping it would work fine in FC13..

Thanks

Comment 1 Sébastien Wilmet 2010-05-16 13:40:20 UTC
I have almost the same Sony Vaio with the same card (Intel HDA ALC269) and it doesn't work for me too.

I've tried to configure PA with pavucontrol and deactivate the HDMI card.
I've also tested to configure ALSA :

echo "options snd_hda_intel model=XXX" >> /etc/modprobe.d/snd_hda_intel.conf

See this page for a list of model names:
http://www.mjmwired.net/kernel/Documentation/sound/alsa/HD-Audio-Models.txt#82

Comment 2 Sébastien Wilmet 2010-05-22 12:19:18 UTC
The sound works perfectly with kernel-2.6.34-2.fc14 :

# yum install fedora-release-rawhide
# yum update --enablerepo=rawhide kernel
# reboot

There was a bug fix about sony vaio and alc269 during the RC5.

Comment 3 Vinayak Kumbhakern 2010-06-27 04:28:08 UTC
Looks like the above kernel with the fix is for Fedora 14... any idea if the fix will be made available for Fedora 13?


But in the meantime I am using following solution (found at https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/537448) which worked for me:

"There is this tool that lets you flip settings around but the changes aren't persistant: http://www.alsa-project.org/main/index.php/HDA_Analyzer

To get my speakers working, I ran the hda_analyzer above and under "Node[0x19]" at the bottom in a pane called "Widget Control", I flipped the VREF to "HIZ" and that did the trick." [*Source*: Arwind Tugade on https://bugs.launchpad.net/ubuntu/+source/linux/+bug/445889)

Comment 4 Sébastien Wilmet 2010-09-12 22:09:44 UTC
> any idea if the fix will be made available for Fedora 13?

kernel-2.6.34 is available in Fedora 13.

The bug should be closed, I think. Unless some people still have the problem...


Note You need to log in before you can comment on or make changes to this bug.