Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592534 - Does not start when gtk3 present
Summary: Does not start when gtk3 present
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 592535 592536 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-15 07:04 UTC by Martin Sourada
Modified: 2011-03-26 15:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-26 15:33:11 UTC


Attachments (Terms of Use)

Description Martin Sourada 2010-05-15 07:04:59 UTC
Description of problem:
Gnome shell refuses to start when gtk3 [1] is installed.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=591222

Version-Release number of selected component (if applicable):
gnome-shell-2.29.1-4.i686

How reproducible:
always

Steps to Reproduce:
1. install gtk3
2. try to start gnome-shell
  
Actual results:
When loading gdk-pixbuf-loader it complains that it cannot load version 2.0, because version 3.0 is already loaded (if you need the exact error I can reproduce it later).

Expected results:
Should start without issues.

Additional info:
After removing gtk3, it starts.

Comment 1 Martin Sourada 2010-05-15 09:58:24 UTC
*** Bug 592535 has been marked as a duplicate of this bug. ***

Comment 2 Martin Sourada 2010-05-15 09:58:32 UTC
*** Bug 592536 has been marked as a duplicate of this bug. ***

Comment 3 Owen Taylor 2011-03-26 15:33:11 UTC
Obviously fine with GTK+-3.0 based GNOME Shell in Fedora 15.


Note You need to log in before you can comment on or make changes to this bug.