Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 5923 - Restore cannot restore files with symlinks.
Summary: Restore cannot restore files with symlinks.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dump
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
: 4815 6950 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-10-13 21:32 UTC by dwmalone
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 18:49:26 UTC


Attachments (Terms of Use)

Description dwmalone 1999-10-13 21:32:09 UTC
When I try to restore a dump with symlinks in it I get
the following messages for each symlink:

% rpm -qf `which restore`
dump-0.4b4-11
% gunzip -c ~/GravesLocal.gz | /sbin/restore xf -
/sbin/restore: ./man: cannot create special file: Operation
not permitted
/sbin/restore: ./mmdf/table/mmdfdbm.db: cannot create
special file: Operation not permitted

It after extracting the files it then thinks it wants
to change tapes on a pipe and aborts, which leaves all
the files with the wrong permissions and wrong ownership.
Restore from another Linux box can successfully restore
the dump file, as can restore on FreeBSD.

Comment 1 Chris Siebenmann 1999-10-21 05:41:59 UTC
This is a bug new in RedHat 6.1; the RedHat 6.0 restore will
restore things fine.

(I also think that this is a fairly severe bug: dump-based backups
cannot be restored easily on RedHat 6.1 machines.)


------- Additional Comments From   11/04/99 08:26 -------
I mailed this to bugzilla, thinking it would get added as a comment,
but didn't. So here goes again.

> + This is a bug new in RedHat 6.1; the RedHat 6.0 restore will
> +restore things fine.

I've just had a quick look - this looks easy enough to fix. A
return was removed in the middle of a switch/case statement, so
the link case was falling through to the special file case.

The mistake seems to be in dump-0.4b4-alpha.patch.

        David.

--- dump-0.4b4/restore/tape.c.redhat    Thu Oct 21 11:51:34 1999
+++ dump-0.4b4/restore/tape.c   Thu Oct 21 11:52:02 1999
@@ -576,6 +576,7 @@
                if (linkit(lnkbuf, name, SYMLINK) == FAIL)
                        return (FAIL);
                (void) chown(name, luid, lgid);
+               return(GOOD);
        }

        case IFCHR:

Comment 2 Bill Nottingham 2000-02-05 18:48:59 UTC
*** Bug 4815 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2000-02-05 18:49:59 UTC
Fixed in the current dump in Raw Hide.

Comment 4 Bill Nottingham 2000-02-05 18:50:59 UTC
*** Bug 6950 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.