Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592279 - Crash while configuring RAID1 partitions using kickstart
Summary: Crash while configuring RAID1 partitions using kickstart
Keywords:
Status: CLOSED DUPLICATE of bug 589967
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
high
Target Milestone: rc
: 6.0
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 12:34 UTC by Rich Johnson
Modified: 2010-05-20 23:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-14 13:51:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rich Johnson 2010-05-14 12:34:07 UTC
Description of problem:
- Crash while configuring RAID1 partitions using kickstart.
- Same effect as  bug 574255; but a different exception
- regression from 6.0-snapshot2

Version-Release number of selected component (if applicable):
6.0-snapshot3

How reproducible:
RAID1 Partition map created using a %pre script
RAID1 Partition map and the same as posted with bug 574255

  
Actual results:
Anaconda raises the exception:
11:56:11,761 CRITICAL: anaconda 13.21.36 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/posixpath.py", line 111, in basename
     i = p.rfind('/') +1
  File "/usr/lib/anaconda/storage/devicetree.py", line 1360, in handleUdevDiskLabelFormat
    bypath=os.path.basename(deviceNameToDiskByPath(device,name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1715, in handleUdevDeviceFormat
    self.handleUdevDiskLabelFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1299, in addUdevDevice
    self.handleUdevDeviceForamt(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1965, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 379 in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103 in storageIntitialize
    storage.reset()
  File "/usr/bin/anaconda", line 1089 in <module>
    storage.storageInitialize(anaconda)
AttributeError: 'NoneType' object has no attribute 'rfind'

Expected results:
  Formatted disk.

Additional info:

Comment 2 Chris Lumens 2010-05-14 13:51:42 UTC

*** This bug has been marked as a duplicate of bug 589967 ***

Comment 3 Andrius Benokraitis 2010-05-20 03:18:30 UTC
Please test Snapshot 4.

Comment 4 Rich Johnson 2010-05-20 23:29:03 UTC
Ssnapshot 4 has resolved this issue.


Note You need to log in before you can comment on or make changes to this bug.