Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592183 - udisks reporting empty label on SDHC drive
Summary: udisks reporting empty label on SDHC drive
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: udisks
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 07:33 UTC by Michel Alexandre Salim
Modified: 2013-03-06 04:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 20:18:56 UTC


Attachments (Terms of Use)

Description Michel Alexandre Salim 2010-05-14 07:33:35 UTC
Description of problem:
udisks does not read the correct partition label on a SDHC card inserted into a Google Nexus One phone. The same setup works fine with dosfslabel, and I've tried resetting the disk label and running fsck.

Version-Release number of selected component (if applicable):
udisks-1.0.1-1.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Plug phone through USB cable, turn on USB storage on phone
2. udisks --show-info /dev/sdd1 | grep label
3. sudo dosfslabel /dev/sdd1
  
Actual results:
Step #2 shows an empty label, thus the disk is mounted using its FAT volume ID. Step #3 correctly shows the label (in this case, NEXUS16G)

Expected results:
udisks should report the correct volume label. This worked fine a couple of days ago.

Additional info:
I just tested a small FAT16 partition I used to flash my computer's BIOS and on it, udisks works just fine.

Comment 1 Michel Alexandre Salim 2010-05-18 20:18:56 UTC
Turns out it was a disk on the verge of failure (after less than a month!). The disk was not even readable in Windows; I managed to get most of the data out, but after that it cannot even be formatted anymore.


Note You need to log in before you can comment on or make changes to this bug.