Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592180 - Spelling error in `virsh nodedev-dettach`
Summary: Spelling error in `virsh nodedev-dettach`
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 07:21 UTC by zhanghaiyan
Modified: 2010-05-14 14:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-14 09:54:43 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description zhanghaiyan 2010-05-14 07:21:33 UTC
Description of problem:
`virsh nodedev-dettach` has spelling error - detach should has  1 't' instead of 2 't'

Version-Release number of selected component (if applicable):
- libvirt-0.8.1-3.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. # virsh help nodedev-dettach
  NAME
    nodedev-dettach - dettach node device from its device driver

  SYNOPSIS
    nodedev-dettach <device>

  DESCRIPTION
    Dettach node device from its device driver before assigning to a domain.

  OPTIONS
    <device>         device key


Actual results:
it uses 'dettach', obviously spelling error

Expected results:
Replcae 'dettach' with 'detach'

Additional info:

Comment 2 RHEL Product and Program Management 2010-05-14 08:37:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Daniel Berrange 2010-05-14 09:54:43 UTC
THis has been known about for a long time, but it cannot be fixed because renaming the command will break any scripts currently using this functionality.

Comment 4 Chris Lalancette 2010-05-14 13:38:55 UTC
However, we could add a shadow command that used exactly the same implementation, but was named correctly.  Then we would have both "virsh nodedev-dettach" and "virsh nodedev-detach", but newer users could use the correct spelling.

Chris Lalancette

Comment 5 Daniel Berrange 2010-05-14 13:58:53 UTC
That will cause more trouble than it is worth, because then people will write scripts / docs using 'nodedev-detach' and they'll not be compatible with any existing deployment.

Comment 6 Bill Nottingham 2010-05-14 14:07:40 UTC
Well, we could certainly backport the right spelling to any production we ship, couldn't we? (I realize you can't *force* people to deploy errata, but...)


Note You need to log in before you can comment on or make changes to this bug.