Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592155 - vesa driver cannot work with KMS driver loaded
Summary: vesa driver cannot work with KMS driver loaded
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-vesa
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ben Skeggs
QA Contact: Boris Ranto
URL:
Whiteboard:
: 592177 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 02:00 UTC by Ben Skeggs
Modified: 2010-11-11 16:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-11 16:31:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed fix (deleted)
2010-05-14 02:00 UTC, Ben Skeggs
no flags Details

Description Ben Skeggs 2010-05-14 02:00:51 UTC
Created attachment 413932 [details]
Proposed fix

Description of problem:

xorg-x11-drv-vesa will cause very bad interactions with KMS drivers, if they're loaded.  Vesa should detect this and refuse to load.

Comment 3 RHEL Product and Program Management 2010-05-14 03:49:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Bill Nottingham 2010-05-14 14:37:30 UTC
*** Bug 592177 has been marked as a duplicate of this bug. ***

Comment 5 Ben Skeggs 2010-05-17 23:23:00 UTC
MODIFIED xorg-x11-drv-vesa-2.2.1-2.el6 is in brew.

Comment 8 releng-rhel@redhat.com 2010-11-11 16:31:05 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.