Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592154 - Directory for hard drive install requires a leading /
Summary: Directory for hard drive install requires a leading /
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Martin Sivák
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-14 01:57 UTC by Andrew Dingman
Modified: 2010-11-10 19:43 UTC (History)
2 users (show)

Fixed In Version: anaconda-13.21.55-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 19:43:21 UTC
Target Upstream Version:


Attachments (Terms of Use)
Anaconda log (deleted)
2010-06-08 23:30 UTC, Andrew Dingman
no flags Details
anaconda.log (deleted)
2010-07-06 13:12 UTC, Alexander Todorov
no flags Details

Description Andrew Dingman 2010-05-14 01:57:10 UTC
Description of problem: When prompted to select the directory for hard drive installation, a leading slash is necessary in the directory name. RHEL 5 did not care. Moreover, the path being specified is a relative path, not an absolute path, and therefore *shouldn't* start with a /, though I'm perfectly happy for that to be tolerated, too.


Version-Release number of selected component (if applicable): RHEL 6 Beta 1


How reproducible: always


Steps to Reproduce:
1. boot RHEL 6 Beta 1 Anaconda
2. Select hard drive installation
3. Choose a partition wich contains the RHEL6.iso and images/ directory in a subdirectory
4. enter the subdirectory name as "subdirectory" or "subdirectory/"
  
Actual results: Anaconda does not find the install media


Expected results: Anaconda finds the install meda


Additional info:

Comment 2 RHEL Product and Program Management 2010-05-14 03:49:48 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Martin Sivák 2010-05-18 13:29:47 UTC
Can you attach the logs please? At least a screenshot of VT3, where we show the anaconda.log. It will easier the debugging. Thanks

Comment 4 Chris Lumens 2010-06-04 17:51:28 UTC
If you can reproduce this and come up with the data requested in comment #3, please feel free to reopen this bug.  To make it in RHEL6 GA, you'll need to do so pretty quickly, though.

Comment 5 Andrew Dingman 2010-06-08 23:30:40 UTC
Created attachment 422381 [details]
Anaconda log

This was done just now, using bits from the 20100603.1 compose for x86_64.

I think the interesting stuff starts at line 43.

This is a mostly-kickstart install where we deliberately leave the install source out of the KS and require manual selection. I typed it without the leading / the first time, and with the 2nd time. Later the install barfs because I named the iso image 'dvd.iso' instead of 'RHEL6.iso', but that is *not* this bug.

Comment 6 Andrew Dingman 2010-06-08 23:33:21 UTC
Re-opening as requested. Sorry for the delay, somehow I missed comment #3 showing up entirely, and then I was busy with a newborn for a couple weeks.

Comment 8 Martin Sivák 2010-06-29 18:33:21 UTC
This will be included in the next version of anaconda.

Comment 10 Alexander Todorov 2010-07-06 13:12:36 UTC
Created attachment 429770 [details]
anaconda.log

With snapshot #7 (0701.3 tree):

1) Select only /dev/vdb1 without entering the directory name - stage2 is started

2) Select vdb1 and enter "images" into the text field - error finding installation image
3) Select vdb1 and enter "images/" into the text field - error finding installation image
4) Select vdb1 and enter "/images" into the text field - error finding installation image
5) Select vdb1 and enter "/images/" into the text field - error finding installation image

6) Select vdb1 and enter "/images/install.img" into the text field - stage2 finally starts. 

anaconda.log is attached (grabbed it after the 6th attempt). Moving back to ASSIGNED.

Comment 11 Martin Sivák 2010-07-07 06:59:42 UTC
And what about "images/install.img"?

Comment 12 Alexander Todorov 2010-07-07 15:15:21 UTC
(In reply to comment #11)
> And what about "images/install.img"?    

stage2 starts.

Comment 13 Martin Sivák 2010-07-12 15:17:31 UTC
So where is the problem?

Comment 14 Andrew Dingman 2010-07-13 16:34:21 UTC
Here's the problem, reproduced just now with beta2 bits. notice the lines starting "14:31:41,824" where I typed "rhel6/isos" as the "Drictory holding image". I *think* Alexander's responses up there may mean it's fixed. I'll test later today with 0707.4 and update the bug with my results.

14:31:31,777 INFO    : starting STEP_STAGE2
14:31:41,805 INFO    : partition /dev/sda1 selected
14:31:41,805 INFO    : mounting device /dev/sda1 for hard drive install
14:31:41,824 INFO    : Path to stage2 image is /mnt/isodirrhel6/isos/images/install.img
14:31:41,824 ERROR   : failed to open /mnt/isodirrhel6/isos/images/install.img: No such file or directory
14:31:41,824 INFO    : umounting loopback /mnt/runtime /dev/loop0
14:31:41,824 ERROR   : LOOP_CLR_FD failed for /mnt/runtime /dev/loop0: No such device or address
14:31:54,813 INFO    : partition /dev/sda1 selected
14:31:54,813 INFO    : mounting device /dev/sda1 for hard drive install
14:31:54,831 INFO    : Path to stage2 image is /mnt/isodir/rhel6/isos/images/install.img
14:31:59,034 INFO    : mounted loopback device /mnt/runtime on /dev/loop0 as /tmp/install.img
14:31:59,035 INFO    : Looking for updates for HD in /mnt/isodir/rhel6/isos/images/updates.img
14:31:59,035 INFO    : Looking for product for HD in /mnt/isodir/rhel6/isos/images/product.img
14:31:59,046 INFO    : mounted loopback device /tmp/product-disk on /dev/loop7 as /mnt/isodir/rhel6/isos/images/product.img
14:31:59,050 INFO    : umounting loopback /tmp/product-disk /dev/loop7
14:31:59,050 ERROR   : LOOP_CLR_FD failed for /tmp/product-disk /dev/loop7: No such device or address
14:31:59,077 INFO    : got stage2 at url hd:/dev/sda1://rhel6/isos/images/install.img

Comment 15 Andrew Dingman 2010-07-14 16:36:37 UTC
Tested with the 20100707.4 build and it's working fine, at least for my use case.

Comment 16 releng-rhel@redhat.com 2010-11-10 19:43:21 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.