Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592093 - Unauthenticated user can delete/create connection
Summary: Unauthenticated user can delete/create connection
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 20:08 UTC by Steve Grubb
Modified: 2010-05-13 21:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-13 21:36:00 UTC


Attachments (Terms of Use)

Description Steve Grubb 2010-05-13 20:08:36 UTC
Description of problem:
If the user slides the authentication window out of the way, they can add or delete connections.

Version-Release number of selected component (if applicable):
virt-manager-0.8.2-3.fc12.noarch

How reproducible:
Always

Steps to Reproduce:
1. Start virt-manager
2. Move authentication window out of the way
3. Right click on kvm connection and select delete
4. Click on the File | Add Connection menu item
5. Add a connection to a Xen system
  
Expected results:
Unauthenticated user should not be able to do anything.

Comment 1 Cole Robinson 2010-05-13 21:36:00 UTC
What is being authenticated is the actual libvirt communication channel, not virt-manager itself. You can cancel the polkit dialog and change virt-manager preferences at will, since they belong to the user running the app. Creating or deleting a connection just makes virt-manager forget about it, it doesn't have any effect on libvirt or vms.


Note You need to log in before you can comment on or make changes to this bug.