Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 592004 - [abrt] crash in evolution-data-server-2.28.3-3: pthread_mutex_unlock, handle_reply
Summary: [abrt] crash in evolution-data-server-2.28.3-3: pthread_mutex_unlock, handle_...
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-data-server
Version: 6.0
Hardware: x86_64
OS: Linux
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
Whiteboard: abrt_hash:ae967a734f6ac11304425d4b919...
: 595502 623797 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2010-05-13 16:57 UTC by Marc Milgram
Modified: 2018-11-26 18:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-05-25 03:02:43 UTC
Target Upstream Version:

Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-13 16:57 UTC, Marc Milgram
no flags Details
Complete stack trace from new incident (deleted)
2010-05-20 17:33 UTC, Marc Milgram
no flags Details

Description Marc Milgram 2010-05-13 16:57:33 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/evolution-data-server-2.28 --oaf-activate-iid=OAFIID:GNOME_Evolution_DataServer_InterfaceCheck --oaf-ior-fd=28
component: evolution-data-server
crash_function: __pthread_mutex_unlock_usercnt
executable: /usr/libexec/evolution-data-server-2.28
global_uuid: ae967a734f6ac11304425d4b9198eb576a1ba9b0
kernel: 2.6.32-25.el6.x86_64
package: evolution-data-server-2.28.3-3.el6
rating: 4
reason: Process /usr/libexec/evolution-data-server-2.28 was killed by signal 11 (SIGSEGV)
release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)

Not sure what causes this bug, but I run into it at least once a day with RHEL6 Beta.  Usually it has been running for a few hours before crashing.

I have 1 mail server configured with imap4s - gssapi.  I have several web-calendars, and one caldav calendar.

How to reproduce
1. Run evolution

Comment 1 Marc Milgram 2010-05-13 16:57:35 UTC
Created attachment 413815 [details]
File: backtrace

Comment 3 RHEL Product and Program Management 2010-05-13 17:47:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for

Comment 4 Marc Milgram 2010-05-20 17:32:26 UTC
Package: evolution-data-server-2.28.3-3.el6
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)

How to reproduce
1. Run Evolution
2. Wait
3. Eventually it gets a SEGFAULT

Ran evolution.  Eventually it crashes.
This may be a dup of BZ 413815, but I have a better stack trace that I will attach.

Comment 5 Marc Milgram 2010-05-20 17:33:52 UTC
Created attachment 415479 [details]
Complete stack trace from new incident

Comment 8 Milan Crha 2010-06-14 09:14:24 UTC
I tried to find a corresponding upstream bug report, but no luck. Could you try to run Evolution under valgrind for some time, whether it'll show anything useful, please? I know if it's a timing issue then the slowness while run under valgrind may hid it, but please try it. I would suggest running these two commands:
   $ export G_SLICE=always-malloc
   $ valgrind evolution &>evo.log
and keep it running for some time, maybe over night. Then there may be something useful in the evo.log file in the morning.

Thanks in advance.

Comment 9 Milan Crha 2010-06-14 09:40:19 UTC
*** Bug 595502 has been marked as a duplicate of this bug. ***

Comment 10 RHEL Product and Program Management 2010-07-15 14:31:55 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 11 Milan Crha 2010-11-16 11:17:57 UTC
*** Bug 623797 has been marked as a duplicate of this bug. ***

Comment 12 Marc Milgram 2010-11-23 14:59:33 UTC

I tried running with valgrind for a week, but it didn't reproduce the issue, and
was painfully  slow.

This week I tried running tcpdump to capture the data between my host and the mail and calendar servers.  Unfortunately most of the data is encrypted.  If it is useful I can provide the tcpdump, and the crash file to someone at Red Hat who can analyse it more thoroughly that I.

Comment 13 Milan Crha 2011-01-17 09:33:38 UTC
The TCP dump is not much useful for me too, unfortunately. It's pity it didn't crash with valgrind, so it seems it's some timing issue, when threads are overlapping. Nonetheless, without some steps/data to reproduce it's hard to tell for sure.

Comment 14 Suzanne Yeghiayan 2011-03-28 21:08:34 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.

Red Hat invites you to ask your support representative to 
propose this request, if appropriate and relevant, in the 
next release of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.