Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591998 - Printing over Fancy HTML Viewer + html2ps does not work
Summary: Printing over Fancy HTML Viewer + html2ps does not work
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: claws-mail-plugins
Version: 13
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 16:35 UTC by Raphael Groner
Modified: 2011-01-24 18:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-01-24 18:15:16 UTC


Attachments (Terms of Use)

Description Raphael Groner 2010-05-13 16:35:39 UTC
Description of problem:
Printing over Fancy HTML Viewer + html2ps does not work. Output is some css garbage text, not the content of the mail.

Version-Release number of selected component (if applicable):
This plugin renders HTML mail using the WebKit 1.1.19 library.

Version: 0.9.9

How reproducible:
Always.

Steps to Reproduce:
1. Click on a Mail with an HTML part.
2. Optionally switch to view the text part.
3. Try to print via File/Print.
  
Actual results:
CSS garbage output

Expected results:
Content of mail.

Additional info:
Why is html2ps no required dependency for claws-mail. Anyway, it does not work in both cases.

Comment 1 Michael Schwendt 2011-01-23 13:56:21 UTC
It would be wrong to make html2ps a dependency of claws-mail. It is fully optional and only needed for printing HTML with either the "fancy" and "gtkhtml2_viewer" plugin. It is not needed for using these plugins for rendering HTML mails.


Further, the error dialog is clear about this optional requirement:

| ERROR
|
| Printing HTML is only possible
| if the program 'html2ps' is installed.


As whether the printed file is broken due to a problem with html2ps or Claws Mail, when printing to a file, it here certainly looks like it was generated from the HTML mail file created below $HOME/.claws-mail/mimetmp/ temporarily.

If you save the mail's html part and run html2ps on it manually, do you get better results? Here, I have a test html mail that results in an empty page if printed either way. It looks to me as if html2ps is the culprit.


> 2. Optionally switch to view the text part.

That works for me and doesn't use "fancy".

Comment 2 Raphael Groner 2011-01-24 18:15:16 UTC
I guess that this issue was with Fedora 13, though I am using Fedora 14 in the meanwhile and claws-mail without any html renderer. Further, I do not have the failing mail any more.

"fancy" and "gtkhtml2_viewer" plugins are each separated packages. I think I did report against the component "claws-mail-plugins" because no more appropriately special component available.

You are right that html2ps is optional. It is a decision of the maintainer to let the user see the print functionality working out-of-the-box or to request an additional installation of html2ps with the pop-up message. Maybe it is good to have dependencies in both special plugin packages - but of course no good idea for the main "claws-mail" package.

Because I can not reproduce any more the exactly same original issue, I will close this bug.


Note You need to log in before you can comment on or make changes to this bug.