Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591987 - [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib64/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in firefox-3.5.9-2.fc12: Process /usr/lib64/firefox-3.5/firefox ...
Keywords:
Status: CLOSED DUPLICATE of bug 555358
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:475d8c116fe57928dff57926469...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 15:58 UTC by Bill Case
Modified: 2010-05-14 11:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-14 11:50:22 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-13 15:58 UTC, Bill Case
no flags Details

Description Bill Case 2010-05-13 15:58:03 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-3.5/firefox
comment: Went to the "Dail Show" on the Canadian Comedy Channel site.  Was contemplating playing one of the "Black on Black" monologues.  As best as I can remember, I hadn't actually clicked on any thing yet, but suddenly FireFox crashed.
component: firefox
crash_function: nsProfileLock::FatalSignalHandler
executable: /usr/lib64/firefox-3.5/firefox
global_uuid: 475d8c116fe57928dff579264699d6c66e7ebde9
kernel: 2.6.32.11-99.fc12.x86_64
package: firefox-3.5.9-2.fc12
rating: 4
reason: Process /usr/lib64/firefox-3.5/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Bill Case 2010-05-13 15:58:06 UTC
Created attachment 413802 [details]
File: backtrace

Comment 2 Chris Campbell 2010-05-14 11:49:12 UTC
#2  <signal handler called>
No symbol table info available.
#3  0x00007f7ecd24c872 in visit_decref (op=0x7f7ed35f4c80, data=0x0)
    at Modules/gcmodule.c:271
        __PRETTY_FUNCTION__ = "visit_decref"
#4  0x00007f7ecd1c1515 in dict_traverse (op=0x7f7ed37121c0, 
    visit=0x7f7ecd24c850 <visit_decref>, arg=0x0) at Objects/dictobject.c:2002
        vret = <value optimized out>
        i = 1
        pk = 0x7f7ed35f4c80
        pv = 0x7f7ecac629f0
#5  0x00007f7ecd24d01f in subtract_refs (generation=<value optimized out>)
    at Modules/gcmodule.c:296
        gc = 0x7f7ed37121a0
#6  collect (generation=<value optimized out>) at Modules/gcmodule.c:817
        i = <value optimized out>
        m = 0
        n = 0
        young = 0x7f7ecd4e21e0
        unreachable = {gc = {gc_next = 0x7f7ec6c6d400, 
            gc_prev = 0x7f7ecd1c17f3, gc_refs = 140735257737446}, 
          dummy = <invalid float value>}
        finalizers = {gc = {gc_next = 0x7f7ede26b9e0, 
            gc_prev = 0x6385124c660dc4b4, gc_refs = 140183041754200}, 
          dummy = <invalid float value>}
        gc = <value optimized out>
        t1 = <value optimized out>
#7  0x00007f7ecd24daba in collect_generations (
    basicsize=<value optimized out>) at Modules/gcmodule.c:924
        i = <value optimized out>
        n = 0
#8  _PyObject_GC_Malloc (basicsize=<value optimized out>)
    at Modules/gcmodule.c:1363
        op = <value optimized out>
        g = 0x7f7ee890fc90
#9  0x00007f7ecd24daee in _PyObject_GC_NewVar (tp=0x7f7ecd4cdb20, nitems=2)
    at Modules/gcmodule.c:1383
        op = <value optimized out>
#10 0x00007f7ecd1db1de in PyTuple_New (size=2) at Objects/tupleobject.c:69
        op = <value optimized out>
        i = <value optimized out>
#11 0x00007f7ecd237807 in r_object (p=0x7fff7b0b0510) at Python/marshal.c:787
        v = <value optimized out>
        v2 = <value optimized out>
        i = <value optimized out>
        n = 2
        type = 40
        retval = <value optimized out>
#12 0x00007f7ecd23784d in r_object (p=0x7fff7b0b0510) at Python/marshal.c:793
        v = 0x7f7ec6c6d820
        v2 = <value optimized out>
        i = <value optimized out>
        n = 87
        type = <value optimized out>
        retval = <value optimized out>



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Chris Campbell 2010-05-14 11:50:22 UTC
Thank you for taking the time to make this bug report.

This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 555358 ***


Note You need to log in before you can comment on or make changes to this bug.