Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591934 - gdb depsolving problems with i386 package on ia64
Summary: gdb depsolving problems with i386 package on ia64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: releng
Version: 5.3.z
Hardware: ia64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Tomas Kopecek
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 14:08 UTC by Jaroslav Kortus
Modified: 2011-09-09 08:36 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-09 08:36:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaroslav Kortus 2010-05-13 14:08:31 UTC
Description of problem:
[root@z3 ~]# yum install gdb
Loaded plugins: rhnplugin, security
Setting up Install Process
Parsing package install arguments
Package gdb-6.8-27.el5.ia64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package gdb.i386 0:6.8-27.el5 set to be updated
--> Processing Dependency: libreadline.so.5 for package: gdb
--> Finished Dependency Resolution
gdb-6.8-27.el5.i386 from rhel-ia64-server-5.3.z has depsolving problems
  --> Missing Dependency: libreadline.so.5 is needed by package gdb-6.8-27.el5.i386 (rhel-ia64-server-5.3.z)
Error: Missing Dependency: libreadline.so.5 is needed by package gdb-6.8-27.el5.i386 (rhel-ia64-server-5.3.z)
[root@z3 ~]# uname -a
Linux z3 2.6.18-128.16.1.el5 #1 SMP Tue Mar 23 14:06:23 EDT 2010 ia64 ia64 ia64 GNU/Linux


Version-Release number of selected component (if applicable):
see above

How reproducible:
100%

Steps to Reproduce:
1. register to z-stream for 5.3.z
2. yum install gdb
3. 
  
Actual results:
only .ia64 version installs

Expected results:
bot ia64 and i386 versions should be able to install. Besides that, installing both of them is the default when doing "yum install gdb".

Additional info:

Comment 1 Jan Kratochvil 2011-01-04 19:03:19 UTC
There was no 5.3.z release of GDB.
http://qafiler.bos.redhat.com/redhat/brewroot/packages/gdb/6.8/

readline.i386 is shipped with RHEL-5.3:
http://qafiler.bos.redhat.com/redhat/released/RHEL-5-Server/U3/ia64/compatlayer/Server/readline-5.1-1.1.i386.rpm

# hostname
ia64-5s-3-m1.ss.eng.bos.redhat.com
# rpm -q redhat-release
redhat-release-5Server-5.3.0.3.ia64
# yum install readline.i386
No package readline.i386 available.

I can confirm the problem exists but it is specific to RHN and I do not know RHN.

Comment 2 Tomas Kopecek 2011-03-07 15:36:28 UTC
readline-5.1-1.1.i386.rpm is still missing from 5.3.z and 5.3.ll ia64 channels. Proposing for 5.3.ll.


Note You need to log in before you can comment on or make changes to this bug.