Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591902 - Cannot change alert sound in GNOME
Summary: Cannot change alert sound in GNOME
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-settings-daemon
Version: 6.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 598944 598959 (view as bug list)
Depends On:
Blocks: 599016
TreeView+ depends on / blocked
 
Reported: 2010-05-13 13:04 UTC by Michal Haško
Modified: 2015-03-02 03:59 UTC (History)
4 users (show)

Fixed In Version: gnome-settings-daemon-2.28.2-6.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-10 20:33:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michal Haško 2010-05-13 13:04:15 UTC
Description of problem:
Selecting a different alert sound in GNOME Sound Preferences dialog doesn't effect the alert sound at all. The same sound (default) is heard when performed a alert-sound generating event (e.g. hitting backspace on empty line in gnome-terminal).

Version-Release number of selected component (if applicable):
gnome-media-2.29.91-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Open "Sound Preferences" dialog
2. In the Sound Effects tab select a different alert sound by clicking the radio button (NOTE: clicking the label doesn't select the radio button).
3. Open gnome-terminal and hit backspace to generate a alert-sound performing event.

  
Actual results:
Same alert sound is heard

Expected results:
Selected alert sound should be heard.

Additional info:

Comment 1 RHEL Product and Program Management 2010-05-13 14:06:55 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 2 Bastien Nocera 2010-05-13 14:14:42 UTC
gnome-volume-control correctly sets /desktop/gnome/sound/theme_name to be "__custom" and a theme is created in ~/.local/share/sounds/__custom/.

The problem is probably with caching.

Could you please start from the "Default" theme (not the default alert sound), and post an *exact* reproducer of the bug?

You can also use "canberra-gtk-play -i bell-window-system" to test whether the sound changed properly.

Comment 3 Michal Haško 2010-05-13 14:49:14 UTC
1. I open the "Sound Preferences" dialog.

2. I set the theme to "Default"
   - The /desktop/gnome/sound/theme_name is set to "freedesktop"
   - "canberra-gtk-play -i bell-window-system" plays the default (from theme) alert sound.

3. I set the alert sound to bark.
   - The /desktop/gnome/sound/theme_name is set to "__custom".
   - Theme is created in ~/.local/share/sounds/__custom/, bell-terminal.ogg and bell-window-system.ogg points to /usr/share/sounds/gnome/default/alerts/bark.ogg.
   - "canberra-gtk-play -i bell-window-system" plays the bark alert
   - producing the terminal bell by hitting backspace in empty terminal prompt plays the default alert sound.

4. I log out & log back in.

5. I open the "Sound Preferences" dialog.
   - The theme is set to Custom, Bark alert is selected,
   - The /desktop/gnome/sound/theme_name is set to "__custom".
   - Theme is created in ~/.local/share/sounds/__custom/, bell-terminal.ogg and bell-window-system.ogg points to /usr/share/sounds/gnome/default/alerts/bark.ogg.
   - "canberra-gtk-play -i bell-window-system" plays the bark alert
   - producing the terminal bell by hitting backspace in empty terminal prompt plays the default alert sound.

6. I reboot the computer.

7. I open the "Sound Preferences" dialog.
   - The theme is set to Custom, Bark alert is selected,
   - The /desktop/gnome/sound/theme_name is set to "__custom".
   - Theme is created in ~/.local/share/sounds/__custom/, bell-terminal.ogg and bell-window-system.ogg points to /usr/share/sounds/gnome/default/alerts/bark.ogg.
   - "canberra-gtk-play -i bell-window-system" plays the bark alert
   - producing the terminal bell by hitting backspace in empty terminal prompt plays the bark alert.

Comment 4 Bastien Nocera 2010-06-02 12:37:50 UTC
*** Bug 598944 has been marked as a duplicate of this bug. ***

Comment 5 Bastien Nocera 2010-06-02 13:48:43 UTC
*** Bug 598959 has been marked as a duplicate of this bug. ***

Comment 6 Bastien Nocera 2010-06-02 14:08:18 UTC
Could you please test with gnome-media-2.29.91-5.el6 ?

Available at, internally:
https://brewweb.devel.redhat.com/buildinfo?buildID=133635

Comment 7 Michal Haško 2010-06-02 15:02:37 UTC
$ rpm -qa | grep gnome-media
gnome-media-2.29.91-5.el6.x86_64
gnome-media-libs-2.29.91-5.el6.x86_64

unfortunately, the bug is still present:
- I set the alert sound to bark.
- The /desktop/gnome/sound/theme_name is set to "__custom".
- Theme is created in ~/.local/share/sounds/__custom/, bell-terminal.ogg and bell-window-system.ogg points to /usr/share/sounds/gnome/default/alerts/bark.ogg.
- "$ canberra-gtk-play -i bell-window-system" plays the bark alert
- Producing the terminal bell by hitting backspace in empty terminal prompt plays the default alert sound.

Comment 8 Bastien Nocera 2010-06-02 15:09:29 UTC
Is gnome-settings-daemon running? If so, please try to run it from a terminal before reproducing the problem, so you can capture the output of it.

Comment 9 Michal Haško 2010-06-03 07:30:12 UTC
I killed the gnome-settings-daemon and rerun it from terminal. The prompt was returned shortly afterwards and the daemon kept running in background. I reproduced the problem and there was no output on the terminal. No difference with a --no-daemon flag.
I currently have gnome-media-2.29.91-6.el6

Comment 11 Bastien Nocera 2010-06-30 09:14:49 UTC
Was a bug in gnome-settings-daemon's packaging, where we remove the sound plugin by mistake.

Fixed in gnome-settings-daemon-2.28.2-6.el6

Comment 13 Jiri Koten 2010-07-23 09:13:50 UTC
Verified in gnome-settings-daemon-2.28.2-6.el6

The Alert sound can be changed.

Comment 14 releng-rhel@redhat.com 2010-11-10 20:33:17 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.