Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591829 - disabling /dev/loop0 LOOP_CLR_FD failed: 16
Summary: disabling /dev/loop0 LOOP_CLR_FD failed: 16
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 09:57 UTC by Liam Li
Modified: 2010-05-18 16:00 UTC (History)
2 users (show)

Fixed In Version: anaconda-14.6-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 16:00:42 UTC


Attachments (Terms of Use)
disable loop (deleted)
2010-05-13 09:57 UTC, Liam Li
no flags Details

Description Liam Li 2010-05-13 09:57:26 UTC
Created attachment 413703 [details]
disable loop

Description of problem:

After install f13-final-rc3, reboot, echoes "disabling /dev/loop0 LOOP_CLR_FD failed: 16". This only appears on the reboot after install finished,does not appear during normal system reboot 
Version-Release number of selected component (if applicable):
anaconda13.42

How reproducible:
always

Steps to Reproduce:
1.install f13-final-rc3
2.after installation completed, press reboot
3.will echo "disabling /dev/loop0 LOOP_CLR_FD failed: 16"
4. but log in installed system, reboot system, this will not happen
  
Actual results:


Expected results:
After install successfully completed, should not give failed information, the screen shot, please see attachment.

Additional info:

Comment 1 Chris Lumens 2010-05-14 15:26:53 UTC
Since we're doing lazy unmounts now (MNT_DETACH in loader/undomounts.c:undoMount), we cannot guarantee that /mnt/runtime will be unmounted when we call undoLoop on /dev/loop0.  That's the device backing that mount point.  However, we should still try because we may want to tear down other loopback devices as well.  Therefore, I think the "fix" here is to just not display an error message.


Note You need to log in before you can comment on or make changes to this bug.