Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591821 - System upgrade fails when ntfs-3g partinition declared in /etc/fstab
Summary: System upgrade fails when ntfs-3g partinition declared in /etc/fstab
Keywords:
Status: CLOSED DUPLICATE of bug 577260
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 09:12 UTC by Krzysztof "Uosiu" Hajdamowicz
Modified: 2010-05-13 13:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-13 13:48:44 UTC


Attachments (Terms of Use)
Traceback from anaconda upgrade process (deleted)
2010-05-13 09:13 UTC, Krzysztof "Uosiu" Hajdamowicz
no flags Details

Description Krzysztof "Uosiu" Hajdamowicz 2010-05-13 09:12:52 UTC
Description of problem:
If there is /etc/fstab entry with parinition type declared as 'ntfs-3g' anaconda fails to upgrade the system, because recognized partinition type is 'ntfs'

Version-Release number of selected component (if applicable):
Unknown, I've used preupgrade to migrate from f12 to f13

How reproducible:
Always

Steps to Reproduce:
1. make /etc/fstab entry with ntfs-3g
    [ uosiu @ samhain ] /home/uosiu > cat /etc/fstab | wklej
    http://wklej.org/id/333007/
2. Try to upgrade existing system
3.
  
Actual results:
Anaconda finds an error and quits

Expected results:
Anaconda updates the system

Additional info:
If you add a '#' at the beginning of declaration of NTFS partinition anaconda works perfectly

Comment 1 Krzysztof "Uosiu" Hajdamowicz 2010-05-13 09:13:54 UTC
Created attachment 413690 [details]
Traceback from anaconda upgrade process

Comment 2 Chris Lumens 2010-05-13 13:48:44 UTC

*** This bug has been marked as a duplicate of bug 577260 ***


Note You need to log in before you can comment on or make changes to this bug.