Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591802 - [abrt] crash in system-config-printer-1.2.2-1.fc13: system-config-printer.py:3622:checkNPName:AttributeError: GUI instance has no attribute 'printers'
Summary: [abrt] crash in system-config-printer-1.2.2-1.fc13: system-config-printer.py:...
Keywords:
Status: CLOSED DUPLICATE of bug 589793
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8327f404
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-13 08:11 UTC by Nikolai Maziashvili
Modified: 2010-05-13 08:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-13 08:57:39 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-13 08:11 UTC, Nikolai Maziashvili
no flags Details

Description Nikolai Maziashvili 2010-05-13 08:11:16 UTC
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.3-85.fc13.i686.PAE
package: system-config-printer-1.2.2-1.fc13
reason: system-config-printer.py:3622:checkNPName:AttributeError: GUI instance has no attribute 'printers'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:3622:checkNPName:AttributeError: GUI instance has no attribute 'printers'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6383, in on_tvNPModels_cursor_changed
    self.on_tvNPDrivers_cursor_changed(self.tvNPDrivers)
  File "/usr/share/system-config-printer/system-config-printer.py", line 6386, in on_tvNPDrivers_cursor_changed
    self.setNPButtons()
  File "/usr/share/system-config-printer/system-config-printer.py", line 4677, in setNPButtons
    self.mainapp.checkNPName(self.entNPName.get_text()))
  File "/usr/share/system-config-printer/system-config-printer.py", line 3622, in checkNPName
    for printer in self.printers.values():
AttributeError: GUI instance has no attribute 'printers'

Local variables in innermost frame:
self: <__main__.GUI instance at 0x93143ac>
name: u'hp-officejet-j6400-series'

Comment 1 Nikolai Maziashvili 2010-05-13 08:11:19 UTC
Created attachment 413673 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-05-13 08:57:39 UTC

*** This bug has been marked as a duplicate of bug 589793 ***


Note You need to log in before you can comment on or make changes to this bug.