Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591749 - v7-1.1-23 fails to setup virtual machine tests and fails to test virtual machines using Xeon RHEL 5.4 or 5.5 kernels
Summary: v7-1.1-23 fails to setup virtual machine tests and fails to test virtual mach...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.1
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 23:34 UTC by Bob Sanders
Modified: 2010-11-18 20:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-18 20:20:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
Sgi Origin 400 eunning RHEL 5.4 Xen (deleted)
2010-05-13 16:57 UTC, Bob Sanders
no flags Details
SGI XE210 running RHEL 5.5 Xen (deleted)
2010-05-13 16:58 UTC, Bob Sanders
no flags Details

Description Bob Sanders 2010-05-12 23:34:47 UTC
Description of problem: fv_* fail to register, and under manual add, fail to execute


Version-Release number of selected component (if applicable):  v7-1.1-23.el5.noarch.rpm


How reproducible: Each time v7 plan is run or v7 plan --add --test=fv_network


Steps to Reproduce:
1. Install v7-1.1-23.el5.noarch.rpm on any RHEL x86_64 system running RHEL 5.4 or 5.5 Xen kernel.

2. execute v7 plan or v7 plan --add --test=fv_network (or fv_core, fv_memory,etc.)
3. v7 certify
  
Actual results:

Running ./fv_network.py:
Using test server 10.1.1.2
Warning: Guest v7x86_64 is already running
Attempting shutdown:
Domain v7x86_64 destroyed

Verified that guest v7x86_64 is not running
Traceback (most recent call last):
  File "./fv_network.py", line 43, in ?
    returnValue = test.do(sys.argv)
  File "/usr/share/v7/lib/v7/test.py", line 255, in do
    return self.run()
  File "./fv_network.py", line 39, in run
    return FvTest.run(self)
  File "/usr/share/v7/lib/v7/fvtest.py", line 435, in run
    if not self.verifyGuest():
  File "/usr/share/v7/lib/v7/fvtest.py", line 142, in verifyGuest
    return self.verifyGuestFiles()
  File "/usr/share/v7/lib/v7/fvtest.py", line 146, in verifyGuestFiles
    if not self.verifyFile(self.guestImageDirectory, self.dataImageFile):
AttributeError: FvNetworkTest instance has no attribute 'guestImageDirectory'
...finished running ./fv_network.py, exit code=1
</output>
recovered exit code=1
v7-report-result /V7/v7/fv_network FAIL /var/log/v7/runs/2/fv_network/output.log 




Expected results:


Additional info:

Comment 1 Greg Nichols 2010-05-13 15:07:28 UTC
Please attach the results of "v7 clean" followed by "v7 plan".   It would be helpful to know if v7 detects that the system is capable of virtualization.

Also, attach the results "cat /proc/cpuinfo | fgrep flags".

Thanks!

Comment 2 Bob Sanders 2010-05-13 16:57:32 UTC
Created attachment 413814 [details]
Sgi Origin 400 eunning RHEL 5.4 Xen

Comment 3 Bob Sanders 2010-05-13 16:58:55 UTC
Created attachment 413817 [details]
SGI XE210 running RHEL 5.5 Xen

Comment 4 Rainer Koenig 2010-05-20 11:32:53 UTC
Hi Greg,

I stumbled over the same issue on my system, testing both X3450 and X3470 CPUs. 
I managed to perform a successful fv_* test with v7-1.0-18 as you can see here:
https://hardware.redhat.com/attachment.cgi?id=413097&action=view

The problem seems to be that evey virtualization site says there should be a "vmx" flag in the output of /proc/cpuinfo, but with those processors there is no such flag. 

From the INFO protocol: 

(8) Intel(R) Xeon(R) CPU X3470 @ 2.93GHz
Arch: 	i386 	L2 Cache: 	8192 KB
Vendor: 	GenuineIntel 	Stepping: 	5
Family: 	6 	CPU Flags: 	fpu tsc msr pae cx8 apic mtrr cmov pat clflush acpi mmx fxsr sse sse2 ss ht nx constant_tsc ida nonstop_tsc pni est ssse3 sse4_1 sse4_2 popcnt [8]

Ok, according to this http://www.gossamer-threads.com/lists/xen/users/168172 it is a normal behaviour of the Xen kernel not to show the vmx flag. 

# cat /sys/hypervisor/properties/capabilities
xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64

So the question is why v7 1.1-23 is not scheduling and running the tests.

Meanwhile I'm back to 1.0-18 for continuing with my tests.

Comment 5 Rob Landry 2010-11-18 20:20:31 UTC
This issue should be addressed as of v7-1.1-24 with the fix included in the v7-1.2 stream.

https://rhn.redhat.com/errata/RHBA-2010-0463.html

I'm going to go ahead and close this bug as fixed/current release.  Please re-open or open a new bug if needed.


Note You need to log in before you can comment on or make changes to this bug.