Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591692 - bnx2x driver on Broadcom BCM57711 gives BAD XGXS ext_phy_config error
Summary: bnx2x driver on Broadcom BCM57711 gives BAD XGXS ext_phy_config error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.8
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Stanislaw Gruszka
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 20:25 UTC by crogers510
Modified: 2018-10-27 14:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-27 21:48:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description crogers510 2010-05-12 20:25:42 UTC
Description of problem:

Broadcom BCM57711 driver shows the following error during boot:

Broadcom NetXtreme II Gigabit Ethernet Driver bnx2 v1.7.9-2 (July 18, 2008)
ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 36 (level, low) -> IRQ 233
PCI: Setting latency timer of device 0000:01:00.0 to 64
divert: allocating divert_blk for eth1
eth1: Broadcom NetXtreme II BCM5716 1000Base-T (C0) PCI Express found at mem d80
00000, IRQ 233, node addr 0026b95ef006
ACPI: PCI Interrupt 0000:01:00.1[B] -> GSI 48 (level, low) -> IRQ 50
PCI: Setting latency timer of device 0000:01:00.1 to 64
divert: allocating divert_blk for eth2
eth2: Broadcom NetXtreme II BCM5716 1000Base-T (C0) PCI Express found at mem da0
00000, IRQ 50, node addr 0026b95ef007
Broadcom NetXtreme II 5771x 10Gigabit Ethernet Driver bnx2x 1.45.23-1 (2008/11/0
3)
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 38 (level, low) -> IRQ 66
PCI: Setting latency timer of device 0000:03:00.0 to 64
divert: allocating divert_blk for eth3
bnx2x: part number 394D4342-31373735-31314131-473331
[bnx2x_link_settings_supported:7195(eth3)]NVRAM config error. BAD XGXS ext_phy_c
onfig 0xff000911
[bnx2x_link_settings_requested:7381(eth3)]NVRAM config error. Invalid link_confi
g 0x1070000  speed_cap_mask 0x500050
eth3: Broadcom NetXtreme II BCM57711 XGb (A0) PCI-E x8 5GHz (Gen2) found at mem 
dc000000, IRQ 66, node addr 0010185fdfd4
ACPI: PCI Interrupt 0000:03:00.1[B] -> GSI 45 (level, low) -> IRQ 74
PCI: Setting latency timer of device 0000:03:00.1 to 64
divert: allocating divert_blk for eth4
bnx2x: part number 394D4342-31373735-31314131-473331
[bnx2x_link_settings_supported:7195(eth4)]NVRAM config error. BAD XGXS ext_phy_c
onfig 0xff000910
[bnx2x_link_settings_requested:7381(eth4)]NVRAM config error. Invalid link_confi
g 0x1070000  speed_cap_mask 0x500050
eth4: Broadcom NetXtreme II BCM57711 XGb (A0) PCI-E x8 5GHz (Gen2) found at mem 
dd000000, IRQ 74, node addr 0010185fdfd6
hw_random hardware driver 1.0.0 loaded


Version-Release number of selected component (if applicable):

Linux xxxxxx 2.6.9-89.0.20.ELlargesmp #1 SMP Mon Jan 18 12:29:35 EST 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

All machines show this error.

Steps to Reproduce:
1. Install Broadcom 57711 card in Dell PE R510 or PE R410
2. Boot RHEL 4.8 AS
3. Driver loads but issues error
  
Actual results:

Card never shows link.


Expected results:

Card would link to 10G switch

Additional info:

This looks like the same issue that was solved under Bug 531882 for RHEL5. I could not find if a similar fix had made it into RHEL4.

Comment 2 Stanislaw Gruszka 2010-05-26 07:39:24 UTC
We do not support new BCM8727 PHY on old RHEL4 driver. As far as I know there are no plans add it (you may ask official RedHat support for that). You have 3 options instead:

- use Broadcom driver from http://www.broadcom.com/support/ethernet_nic/netxtremeii10.php , I think it works on RHEL4
- update to RHEL5
- backport fix by yourself

I'm going to close that bug with WANTFIX resolution.

Comment 3 Stanislaw Gruszka 2010-05-26 07:46:26 UTC
(In reply to comment #2)
> I'm going to close that bug with WANTFIX resolution.
Or not, actually we have to think if it's worth to add new hardware support for RHEL4.

Comment 4 Andrius Benokraitis 2010-05-27 21:48:15 UTC
Correct. RHEL 4.8 was the final minor release for including driver features. The 57711 was finalized upstream after the RHEL 4.8 development window. RHEL 4.9 will not have any new driver enablement. Please upgrade to RHEL 5, or use an out-of-box driver supplied by Broadcom (if available).

Comment 5 Stanislaw Gruszka 2010-05-28 09:40:05 UTC
FYI: There should be also possibility to change card SFP module to one that RHEL4 driver support. I think Broadcom can give some recommendation about working SFPs with bnx2x in version 1.45.23-1.

Comment 6 Eilon Greenstein 2010-05-28 10:07:41 UTC
It’s not the optic module, it is the PHY on that board. This type of board is not supported in that version of bnx2x.


Note You need to log in before you can comment on or make changes to this bug.