Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591686 - wine-core missing dependencies
Summary: wine-core missing dependencies
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: wine
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 20:18 UTC by Michael Cronenworth
Modified: 2010-05-12 21:01 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 20:35:36 UTC


Attachments (Terms of Use)

Description Michael Cronenworth 2010-05-12 20:18:32 UTC
Description of problem: wine will not execute.


Version-Release number of selected component (if applicable): wine-1.1.44-2.fc12 (both 32-bit and 64-bit version)


How reproducible: Always


Steps to Reproduce:
1. yum --enablerepo=updates-testing install wine-core.x86_64 wine-pulseaudio.x86_64 wine-common
2. winecfg
or
1. yum --enablerepo=updates-testing install wine-core.i686 wine-pulseaudio.i686 wine-common
2. winecfg
  
Actual results:
Wine does not work.
$ winecfg
wine: created the configuration directory '/home/mcronenworth/.wine'
wine: could not exec wineserver
$ winemine
wine: could not exec wineserver
$ wine asdf
wine: could not exec wineserver

Expected results:
Working wine.

Additional info:
I removed ~/.wine before creating this bug report.

Downgrading to wine-1.1.38 results in wine working again. Perfectly. Upgrading back to wine-1.1.44 from updates-testing yields the same results as my description at the top of this bug report.

$ rpm -q kernel
kernel-2.6.32.11-99.fc12.x86_64

Comment 1 Andreas Bierfert 2010-05-12 20:35:36 UTC
This is not a bug. Either install the wine meta package which pulls in everything needed for wine to run smoothly, or in your case at least also install the needed wine-wow package.

Comment 2 Michael Cronenworth 2010-05-12 20:46:24 UTC
If wine-wow is required for wine-core to function, then it should be a Requires: otherwise "yum install wine-core" results in wasted hard drive space.

Comment 3 Andreas Bierfert 2010-05-12 21:01:43 UTC
wine-core is not meant to be installed standalone. wine-core cannot require wine-wow because of the different package sets which are needed on 32bit and 64bit boxes (please take a look at the spec) where both wine-wow(x86-32) and wine-wow(x86-64) conflict but wine-core(x86-32) and wine-core(x86-64) need to be installed in parallel.

I know that this seems a bit strange but hence the wine meta package.


Note You need to log in before you can comment on or make changes to this bug.