Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591671 - [abrt] crash in gedit-1:2.28.3-1.fc12: list index out of range
Summary: [abrt] crash in gedit-1:2.28.3-1.fc12: list ...
Alias: None
Product: Fedora
Classification: Fedora
Component: gedit
Version: 12
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
Whiteboard: abrt_hash:2d8d2906
Depends On:
TreeView+ depends on / blocked
Reported: 2010-05-12 19:42 UTC by olivier
Modified: 2010-12-03 14:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 663409 (view as bug list)
Last Closed: 2010-12-03 14:46:08 UTC

Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-12 19:42 UTC, olivier
no flags Details

Description olivier 2010-05-12 19:42:36 UTC
abrt 1.0.9 detected a crash.

architecture: i686
cmdline: gedit
component: gedit
executable: /usr/lib/gedit-2/plugins
package: gedit-1:2.28.3-1.fc12
reason: list index out of range
release: Fedora release 12 (Constantine)

----- list index out of range

Traceback (most recent call last):
  File "/usr/lib/gedit-2/plugins/GeditLaTeXPlugin/src/base/", line 212, in <lambda>
    self._handler = self._internal_action.connect("activate", lambda gtk_action, action: action.activate(window_context), self)
  File "/usr/lib/gedit-2/plugins/GeditLaTeXPlugin/src/latex/", line 97, in activate
  File "/usr/lib/gedit-2/plugins/GeditLaTeXPlugin/src/latex/", line 515, in source
    template_string = open(self._proxy_template.value).read()
  File "/usr/lib/gedit-2/plugins/GeditLaTeXPlugin/src/latex/", line 135, in value
    return self._options[index][0]
IndexError: list index out of range

Local variables in innermost frame:
index: -1
self: <GeditLaTeXPlugin.src.latex.dialogs.ComboBoxProxy object at 0x9db79ec>

How to reproduce
1.install plugin latex for gedit and crashed when creating a new doc

Comment 1 olivier 2010-05-12 19:42:38 UTC
Created attachment 413538 [details]
File: backtrace

Comment 2 vaccaaa 2010-07-22 19:18:29 UTC
Package: gedit-1:2.30.2-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)

How to reproduce
1. Try to create a New latex document
2. Click OK

I tried to create a new latex document (File-> new latex document). Then I clicked on OK and waited. ABRT returned me a crash, no new file was created, nor any new instance of gedit was opened

Comment 3 Alexander Volovics 2010-07-29 11:50:02 UTC
Package: gedit-1:2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)

How to reproduce
1.install latex plugin new latex document 
3.fill in the necessary menu items in popup window

Wanted to open new latex document.
After filling in the popup window menu the bug reporting window appeared

Comment 4 Alexey 2010-10-06 17:49:26 UTC
Package: gedit-1:2.30.2-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)

How to reproduce
----- file->NewLaTEX document

Comment 5 Kvikende 2010-10-18 12:33:18 UTC
Package: gedit-1:2.30.2-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)

How to reproduce
1. I tried to make a new LaTex document.

Comment 6 Bug Zapper 2010-11-03 15:00:00 UTC
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here:

Comment 7 jesus 2010-11-04 20:43:47 UTC
Package: gedit-2:2.30.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)

How to reproduce
----- a new latex document on gedit

Comment 8 Bug Zapper 2010-12-03 14:46:08 UTC
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.