Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591643 - [abrt] crash in ImpEditView::ShowCursor
Summary: [abrt] crash in ImpEditView::ShowCursor
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:2b3168a6be25e67e73703b96adf...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 18:39 UTC by Erik Johnson
Modified: 2010-05-18 11:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-18 11:48:33 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-12 18:39 UTC, Erik Johnson
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenOffice.org 94322 None None None Never

Description Erik Johnson 2010-05-12 18:39:46 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/openoffice.org3/program/scalc.bin -calc
component: openoffice.org
crash_function: GetObject
executable: /usr/lib64/openoffice.org3/program/scalc.bin
global_uuid: 2b3168a6be25e67e73703b96adffde855719b0bf
kernel: 2.6.32.11-99.fc12.x86_64
package: openoffice.org-calc-1:3.1.1-19.28.fc12
rating: 4
reason: Process /usr/lib64/openoffice.org3/program/scalc.bin was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

How to reproduce
-----
1.Enter multi-line value in a cell (ctrl+enter)
2.See mistake and double-click the cell to edit-in-place
3.???
4.Priofit

Comment 1 Erik Johnson 2010-05-12 18:39:48 UTC
Created attachment 413520 [details]
File: backtrace

Comment 2 David Tardon 2010-05-13 07:15:59 UTC
Likely related to a11y, but I cannot reproduce it and valgrind gives no hint. Can you reproduce it? If yes, could you attach a sample spreadsheet?

Comment 3 Caolan McNamara 2010-05-13 07:51:13 UTC
Possibly fixed by "2009-03-13 13:43:54 +0100 tl  r269476 : #i94322# ImpEditView::ShowCursor and nPara == USHRT_MAX problem fixed" ?

Comment 4 Caolan McNamara 2010-05-18 11:48:33 UTC
Let's assume that. Will be good in F-13 if that's the case


Note You need to log in before you can comment on or make changes to this bug.