Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591633 - Firewall prevents discovery of mDNS devices
Summary: Firewall prevents discovery of mDNS devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: system-config-printer
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 638176 728138
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 18:03 UTC by Issue Tracker
Modified: 2018-11-14 19:31 UTC (History)
8 users (show)

Fixed In Version: system-confing-printer-1.1.16-19.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 15:31:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1638 normal SHIPPED_LIVE system-config-printer bug fix update 2011-12-06 00:50:40 UTC

Description Issue Tracker 2010-05-12 18:03:29 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2010-05-12 18:03:31 UTC
Event posted on 05-12-2010 01:18pm EDT by woodard

Description of problem:
When you run hp-toolbox and try to setup a device it can't seem to find the device over the network. Other OS's have no problem. This happens even if you increase the timeout and toggle between mDNS/Bonjour or SLP

How reproducible:
always

Steps to Reproduce:

Actual results:
Nothing found

Expected results:
find's the printer

Additional info:
hplip-3.9.8-30.el6.x86_64

When you do a manual find it finds it with no problem.

This event sent from IssueTracker by kbaxley  [LLNL (desktop)]
 issue 882113

Comment 2 RHEL Product and Program Management 2010-05-12 18:07:46 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Bill Nottingham 2010-05-12 22:15:42 UTC
What are your firewall settings?

Comment 4 Issue Tracker 2010-05-13 16:18:04 UTC
Event posted on 2010-05-13 09:18 PDT by woodard

pretty light and pretty standard

# Firewall configuration written by system-config-firewall
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
-A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-I FORWARD -m physdev --physdev-is-bridged -j ACCEPT
-A INPUT -j REJECT --reject-with icmp-host-prohibited
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
COMMIT
/etc/sysconfig/iptables (END) 





This event sent from IssueTracker by woodard 
 issue 882113

Comment 5 Tim Waugh 2010-05-17 14:17:02 UTC
The default firewall prevents slp and mdns replies.  You need to adjust the firewall in order to discover network printers.

Comment 28 errata-xmlrpc 2011-12-06 15:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1638.html


Note You need to log in before you can comment on or make changes to this bug.