Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591591 - [abrt] crash in lmms-0.4.6-2.fc12: QMetaObject::removeGuard: Process /usr/bin/lmms was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in lmms-0.4.6-2.fc12: QMetaObject::removeGuard: Process /usr/bin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lmms
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Thomas Moschny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:83877c46060f764cd2135d6240f...
: 568808 593161 614309 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 16:05 UTC by Martin Airs
Modified: 2010-09-15 22:30 UTC (History)
5 users (show)

Fixed In Version: lmms-0.4.8-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-15 22:30:52 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-12 16:05 UTC, Martin Airs
no flags Details

Description Martin Airs 2010-05-12 16:05:56 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/lmms
comment: not doing anything in particular, its crashed 3 times now at random moments, i was actualy just playing a sample on the piano roll, nothing major
component: lmms
crash_function: QMetaObject::removeGuard
executable: /usr/bin/lmms
global_uuid: 83877c46060f764cd2135d6240f7b9e512fb4a70
kernel: 2.6.32.11-99.fc12.x86_64
package: lmms-0.4.6-2.fc12
rating: 4
reason: Process /usr/bin/lmms was killed by signal 11 (SIGSEGV)
release: Fedora release 12 (Constantine)

Comment 1 Martin Airs 2010-05-12 16:05:58 UTC
Created attachment 413472 [details]
File: backtrace

Comment 2 discohr 2010-05-14 06:42:30 UTC
Package: lmms-0.4.6-2.fc12
Architecture: x86_64
OS Release: Fedora release 12 (Constantine)


How to reproduce
-----
1. Start LMMS.
2. In Beat+Bassline Editor doubleclick a pattern to open it in Piano-Roll.
3. Click left mouse button on any key (C4 will do) in Piano-Roll and hold it down.
4. Move mouse fast up and down along keyboard. LMMS will crash in a second or two.


Comment
-----
Moving mouse fast along keyboard in Piano-Roll while holding left mouse button crashes LMMS.

Comment 3 Karel Klíč 2010-05-25 09:46:42 UTC
*** Bug 568808 has been marked as a duplicate of this bug. ***

Comment 4 Karel Klíč 2010-05-25 09:46:46 UTC
*** Bug 593161 has been marked as a duplicate of this bug. ***

Comment 5 Ruben 2010-06-01 23:24:41 UTC
This is not only on RedHat, I have the same problem running 64-bit Xubuntu, and my mom has it running 32-bit Ubuntu as well.

Same deal with the crash in removeGuard. I am suspecting that maybe some child object is being allocated on the stack... that's a total guess at this point though.

Comment 6 Stian Ellingsen 2010-07-14 06:30:13 UTC
*** Bug 614309 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-09-05 23:12:56 UTC
lmms-0.4.8-1.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/lmms-0.4.8-1.fc12

Comment 9 Fedora Update System 2010-09-08 02:28:18 UTC
lmms-0.4.8-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update lmms'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/lmms-0.4.8-1.fc12

Comment 10 Fedora Update System 2010-09-15 22:30:48 UTC
lmms-0.4.8-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.