Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591583 - weird bash behaviour in F13 with wildcards
Summary: weird bash behaviour in F13 with wildcards
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Roman Rakus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 15:49 UTC by Joachim Backes
Modified: 2014-01-13 00:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 15:57:57 UTC


Attachments (Terms of Use)

Description Joachim Backes 2010-05-12 15:49:33 UTC
Description of problem:
the F13 bash seems to behave incorrect:

If you have only the files a,B and z in some directory (not more), then 
the command "echo [a-z]" only should echo the text "a z"
But the bash in F13 echoes the text: "a B z".

Can this behavior depend on environment variables?

Version-Release number of selected component (if applicable):
bash-4.1.2-4.fc13.i686

How reproducible:
Always

Steps to Reproduce:
1.mkdir x;cd x;touch a B z
2.echo [a-z]
3
  
Actual results:
a B z
Expected results:
a z

Additional info:
1. Usage of zsh instead echoes "a z" (as expected).
2. Weird: Downloading bash-3.2.tar.gz from gnu.org and installing this bash
   shows the same wrong behaviour.
3. Using zsh instead of bash in F13 echoes "a z" and not "a B z". That is 
   correct too.
4. I checked this in earlier Fedoras, there the behaviour is correct (as 
   described: echoes "a z").

Comment 1 Joachim Backes 2010-05-12 15:57:57 UTC
Sorry, I forget to set LC_ALL=C in the environment. With this, "a z" is echoed as expected (thanks to Eric Blake).


Note You need to log in before you can comment on or make changes to this bug.