Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591578 - netrw.vim print additional 'e' in front of filenames
Summary: netrw.vim print additional 'e' in front of filenames
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vim
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: Petr Šplíchal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 15:35 UTC by Kirby Zhou
Modified: 2016-06-01 01:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1031691 (view as bug list)
Environment:
Last Closed: 2013-01-08 07:33:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0066 normal SHIPPED_LIVE vim bug fix update 2013-01-07 15:27:30 UTC

Internal Links: 594997

Description Kirby Zhou 2010-05-12 15:35:16 UTC
Description of problem:


Version-Release number of selected component (if applicable):

vim-7.0.109-6.el5

How reproducible:

100%

Steps to Reproduce:
mkdir tmp
cd tmp
touch .vimrc
LC_CTYPE=zh_CN.gbk vim .  

Actual results:
YOU CAN SEE an additional 'e' in front of '../'.

" ============================================================================
" Netrw Directory Listing                                        (netrw v125)
"   /root/tmp
"   Sorted by      name
"   Sort sequence: [\/]$,\.h$,\.c$,\.cpp$,*,\.o$,\.obj$,\.info$,\.swp$,\.bak$,\~$
"   Quick Help: <F1>:help  -:go up dir  D:delete  R:rename  s:sort-by  x:exec
" ============================================================================
.vimrc
e../
~                                                                                                                                  
Expected results:

" ============================================================================
" Netrw Directory Listing                                        (netrw v125)
"   /root/tmp
"   Sorted by      name
"   Sort sequence: [\/]$,\.h$,\.c$,\.cpp$,*,\.o$,\.obj$,\.info$,\.swp$,\.bak$,\~$
"   Quick Help: <F1>:help  -:go up dir  D:delete  R:rename  s:sort-by  x:exec
" ============================================================================
.vimrc
../
~                                                                                                                                  

Additional info:

/usr/share/vim/vim70/autoload/netrw.vim 
please check line 5802.

5800 "     call Decho("remove priority pattern prefix")
5801      let sepchr= "\<Char-0xff>"
5802      exe 'silent keepjumps '.w:netrw_bannercnt.',$s/^\d\{3}'.sepchr.'//e'
5803 
5804     elseif a:islocal

Comment 2 RHEL Product and Program Management 2012-07-03 15:47:05 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.

Comment 6 errata-xmlrpc 2013-01-08 07:33:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0066.html


Note You need to log in before you can comment on or make changes to this bug.