Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591557 - buttons in interactive forms don't work in evince
Summary: buttons in interactive forms don't work in evince
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: poppler
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Marek Kašík
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 662543
TreeView+ depends on / blocked
 
Reported: 2010-05-12 14:45 UTC by Issue Tracker
Modified: 2018-12-05 15:14 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 866485 (view as bug list)
Environment:
Last Closed: 2013-10-07 01:39:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
interactive form that reproduces the issue (deleted)
2010-05-12 14:46 UTC, Kent Baxley
no flags Details

Description Issue Tracker 2010-05-12 14:45:07 UTC
Escalated to Bugzilla from IssueTracker

Comment 1 Issue Tracker 2010-05-12 14:45:08 UTC
Event posted on 05-12-2010 10:37am EDT by woodard

Description of problem:
Neither the print of the clear buttons at the bottom of this interactive form work.

How reproducible:
always

Steps to Reproduce:
add something to the form by clicking on the fields and entering some data
try hitting the print form button at the bottom - nothing happens
try hitting the clear form button at the bottom - nothing happens

Actual results:
nothin

Expected results:
it prints or clears

Additional info:
evince-2.28.2-8.el6.x86_64
This event sent from IssueTracker by kbaxley  [LLNL (desktop)]
 issue 880893

Comment 2 Kent Baxley 2010-05-12 14:46:24 UTC
Created attachment 413448 [details]
interactive form that reproduces the issue

Comment 3 RHEL Product and Program Management 2010-05-12 15:46:29 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Marek Kašík 2010-05-14 12:54:19 UTC
Hi,

poppler is responsible for handling of PDFs in evince. I'm reassigning this.
Actions Named->Print and ResetForm are not implemented yet. So this is a feature request.

Marek

Comment 5 Marek Kašík 2010-05-17 13:07:31 UTC
I'm changing version of Red Hat Enterprise Linux to 6.1.

Comment 7 Suzanne Yeghiayan 2011-01-05 19:40:27 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated 
in the current release, Red Hat is unfortunately unable to 
address this request at this time.  This request has been 
proposed for the next release of Red Hat Enterprise Linux.
If you would like it considered as an exception in the 
current release, please ask your support representative.

Comment 8 Ben Woodard 2011-01-06 19:22:31 UTC
So this might explain why evince doesn't implement the full acrobat forms language http://www.youtube.com/watch?v=4F2xMw3987I

Comment 9 RHEL Product and Program Management 2011-07-06 01:02:49 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 11 Tom Lavigne 2012-09-18 15:21:30 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.
    
Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 12 Ben Woodard 2012-09-18 17:54:40 UTC
The problem still exists in "Document Viewer" 3.4.0 in F17. Since this problem doesn't look like it is going to get addressed in RHEL6 can we please move it to RHEL7 and F18

Comment 13 Leslie Satenstein 2013-05-27 00:17:38 UTC
In Fedora 19 Rc4 64bit version, the Envince buttons to print the document and to perform other actions is non-existant.

There appears to be a missing menu

Comment 15 Andrius Benokraitis 2013-10-07 01:39:35 UTC
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6, and will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.


Note You need to log in before you can comment on or make changes to this bug.