Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591503 - [abrt] crash in virt-manager-0.8.2-3.fc12: raise: Process /usr/bin/python was killed by signal 6 (SIGABRT)
Summary: [abrt] crash in virt-manager-0.8.2-3.fc12: raise: Process /usr/bin/python was...
Keywords:
Status: CLOSED DUPLICATE of bug 544305
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:297b2775a3820a7baa5759309f1...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 12:32 UTC by Richard A Lochner
Modified: 2010-05-12 14:01 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 14:01:05 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-12 12:32 UTC, Richard A Lochner
no flags Details

Description Richard A Lochner 2010-05-12 12:32:01 UTC
abrt 1.0.9 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: python /usr/share/virt-manager/virt-manager.py --debug --no-dbus --no-fork --sync -c qemu+tls://vmh001.clone1.com/system
component: virt-manager
crash_function: raise
executable: /usr/bin/python
global_uuid: 297b2775a3820a7baa5759309f1a99303b539a64
kernel: 2.6.32.11-99.fc12.x86_64
package: virt-manager-0.8.2-3.fc12
rating: 4
reason: Process /usr/bin/python was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

comment
-----
When opening a window to a VM with virt-manager, it aborts with the following error:
python: ath.c:193: _gcry_ath_mutex_lock: Assertion `*lock == ((ath_mutex_t) 0)' failed.

Usually, the window will open for a few seconds before the crash occurs.

The log file ends with the following:

2010-05-12 07:24:11,946 (console:562): Graphics console configured at vnc://vmh001.clone1.com:5900
2010-05-12 07:24:11,948 (console:575): Starting connect process for vmh001.clone1.com 5900
2010-05-12 07:24:11,983 (engine:414): window counter incremented to 2
2010-05-12 07:24:11,988 (console:562): Graphics console configured at vnc://vmh001.clone1.com:5900
2010-05-12 07:24:11,990 (console:575): Starting connect process for vmh001.clone1.com 5900
2010-05-12 07:24:12,721 (console:626): Got credential request <enum VNC_DISPLAY_CREDENTIAL_CLIENTNAME of type VncDisplayCredential>
2010-05-12 07:24:12,836 (console:464): VNC initialized
python: ath.c:193: _gcry_ath_mutex_lock: Assertion `*lock == ((ath_mutex_t) 0)' failed.

How to reproduce
-----
I ran virt-manager as follows:
virt-manager --debug --no-dbus --no-fork --sync -c qemu+tls://vmh001.clone1.com/system 2>virt-manager.log

Comment 1 Richard A Lochner 2010-05-12 12:32:03 UTC
Created attachment 413415 [details]
File: backtrace

Comment 2 Daniel Berrange 2010-05-12 13:57:22 UTC
Please provide the precise gtk-vnc and libvirt  RPM versions installed. Looks like a libvirt bug to me though.

Comment 3 Cole Robinson 2010-05-12 14:01:05 UTC
There's a nearly identical bug against libvirt, so just duping to that.

*** This bug has been marked as a duplicate of bug 544305 ***


Note You need to log in before you can comment on or make changes to this bug.