Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591484 - [abrt] crash in gnome-settings-daemon-2.30.1-4.fc13: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
Summary: [abrt] crash in gnome-settings-daemon-2.30.1-4.fc13: Process /usr/libexec/gno...
Keywords:
Status: CLOSED DUPLICATE of bug 592158
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:bc7e6de6435d7cf85475fd38a6c...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 11:40 UTC by Jaroslav Pulchart
Modified: 2010-05-25 10:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-25 10:36:34 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2010-05-12 11:40 UTC, Jaroslav Pulchart
no flags Details

Description Jaroslav Pulchart 2010-05-12 11:40:52 UTC
abrt 1.1.0 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/gnome-settings-daemon
component: gnome-settings-daemon
crash_function: gkbd_indicator_config_load_font
executable: /usr/libexec/gnome-settings-daemon
global_uuid: bc7e6de6435d7cf85475fd38a6c0bc247bfdfb20
kernel: 2.6.33.3-85.fc13.x86_64
package: gnome-settings-daemon-2.30.1-4.fc13
rating: 4
reason: Process /usr/libexec/gnome-settings-daemon was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
gnome-settings-[29010]: segfault at 210 ip 0000003be6608636 sp 00007fff4e3a8250 error 4 in libgnomekbdui.so.4.1.0[3be6600000+14000]

How to reproduce
-----
1. Login to GNOME session
2.
3.

There must exist custom xorg configuration file in /etc/xorg.conf.d/ dir.

 /etc/xorg.conf.d/10-myfile.conf
----------------------
Section "Device"
    Identifier          "Built-in Intel GS45 Graphics"
    Driver              "intel"

    Option              "monitor-LVDS1" "Builtin LCD"
    Option              "monitor-VGA1" "Disabled Monitor"
    Option              "monitor-HDMI1" "Disabled Monitor"
    Option              "monitor-HDMI2" "External LCD"
    Option              "monitor-DP1" "Disabled Monitor"
    Option              "monitor-DP2" "Disabled Monitor"
    Option              "monitor-DP3" "Disabled Monitor"
EndSection


Section "Monitor"
    Identifier          "Builtin LCD"
Endsection

Section "Monitor"
    Identifier          "External LCD"
Endsection

Section "Monitor"
    Identifier          "Disabled Monitor"
    Option              "Ignore" "true"
EndSection

Section "Screen"
    Identifier          "Main Display"
    Device              "Built-in Intel GS45 Graphics"
EndSection

Section "ServerLayout"
    Identifier          "Default Layout"
    Screen              "Main Display"
EndSection
----------------------

Login is OK when "ServerLayout" and "Screen" section is not used in  /etc/xorg.conf.d/10-myfile.conf

Comment 1 Jaroslav Pulchart 2010-05-12 11:40:55 UTC
Created attachment 413401 [details]
File: backtrace

Comment 2 Karel Klíč 2010-05-25 10:36:34 UTC

*** This bug has been marked as a duplicate of bug 592158 ***

Comment 3 Karel Klíč 2010-05-25 10:36:34 UTC
This bug appears to have been filled using a buggy version of ABRT, because
it contains a backtrace which is a duplicate of backtrace from bug #592158.

Sorry for the inconvenience.


Note You need to log in before you can comment on or make changes to this bug.