Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591399 - Liveinst fails, anaconda crashes with debug
Summary: Liveinst fails, anaconda crashes with debug
Keywords:
Status: CLOSED DUPLICATE of bug 590384
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ales Kozumplik
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 06:55 UTC by Grant Williamson
Modified: 2014-09-30 23:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-13 07:47:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
EL6 Liveinst anaconda crashes (deleted)
2010-05-12 06:55 UTC, Grant Williamson
no flags Details

Description Grant Williamson 2010-05-12 06:55:21 UTC
Created attachment 413339 [details]
EL6 Liveinst anaconda crashes

Description of problem:
Trying to install el6 snapshot 2 from livedvd to disk.


Version-Release number of selected component (if applicable):
RHEL6.0-20100428.3
anaconda-13.12.32-1

How reproducible:
Create live dvd of el6.
Boot livedvd, login.
Run liveinst as user.
Select - US English.
Select - Install Anyway
Select - Basic Storage
Select - VMWare Disk
Hostname - local host
City - NewYork
Select - Use All Space
Write Changes to Disk
Disk gets formatted.
Anaconda crashes.

See log - anaconda-tb-PIf9PAW4NWuY.xml

Comment 2 RHEL Product and Program Management 2010-05-12 08:22:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Chris Lumens 2010-05-12 13:49:14 UTC
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 416, in lvdeactivate
    raise LVMError("lvdeactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 2325, in teardown
    lvm.lvdeactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/__init__.py", line 2000, in umountFilesystems
    device.teardown()
  File "/usr/lib/anaconda/storage/__init__.py", line 1131, in umountFilesystems
    self.fsset.umountFilesystems(ignoreErrors=ignoreErrors, swapoff=swapoff)
  File "/usr/lib/anaconda/livecd.py", line 174, in doPreInstall
    anaconda.id.storage.umountFilesystems(swapoff = False)
  File "/usr/lib/anaconda/backend.py", line 297, in doPreInstall
    anaconda.backend.doPreInstall(anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1258, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 79, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1279, in handleRenderCallback
    self.currentWindow.renderCallback()
LVMError: lvdeactivate failed for lv_swap: 04:53:06,101 ERROR   :   LV VolGroup/lv_swap in use: not deactivating

Comment 5 Ales Kozumplik 2010-05-13 07:47:40 UTC

*** This bug has been marked as a duplicate of bug 590384 ***


Note You need to log in before you can comment on or make changes to this bug.