Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591386 - VT swallows keys
Summary: VT swallows keys
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: plymouth
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 05:39 UTC by Qian Cai
Modified: 2010-05-22 19:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-22 19:40:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
initramfs (deleted)
2010-05-14 05:08 UTC, Qian Cai
no flags Details
initramfs (deleted)
2010-05-22 15:48 UTC, Qian Cai
no flags Details

Description Qian Cai 2010-05-12 05:39:28 UTC
Description of problem:
When login from a VT, several previous typed keys are discarded (without any sign on the screen) before it accepts the input for username/password.

Version-Release number of selected component (if applicable):
RHEL6 public beta 1 x86_64

How reproducible:
always

Comment 1 Qian Cai 2010-05-12 06:46:53 UTC
It behaved strangely. Sometimes, it did not accept ENTER key only. If it started in runlevel 5, and then switched back to VT, everything was working fine.

Comment 2 Qian Cai 2010-05-12 09:16:51 UTC
This looks like a KMS bug since it went away by adding nomodeset on both ATI and Intel graphic systems.

Comment 3 Qian Cai 2010-05-12 09:36:22 UTC
Hmm, the problem also went away by removing "rhgb quiet".

Comment 4 Ray Strode [halfline] 2010-05-12 13:58:58 UTC

*** This bug has been marked as a duplicate of bug 582265 ***

Comment 5 Qian Cai 2010-05-13 01:42:23 UTC
The problem is still persistent after upgraded to plymouth-0.8.3-1.el6.

Comment 6 Ray Strode [halfline] 2010-05-13 02:01:24 UTC
Note after upgrading to plymouth-0.8.3-1.el6 you need to rebuild your initrd with /usr/libexec/plymouth/plymouth-update-initrd or by installing a new kernel.

I'm going to close this bug because it really sounds like a bug that's already been fixed.  If after rebuilding your initrd you still have a problem, please reopen.

Comment 7 Qian Cai 2010-05-13 05:55:59 UTC
After running the command, I am getting,
"could not start boot splash: Can not access a needed shared library"

Comment 8 Ray Strode [halfline] 2010-05-13 12:22:01 UTC
That means plymouthd couldn't find a boot splash to load.   This shouldn't happen if your initrd was generated properly.

what's the output of 

/usr/sbin/plymouth-set-default-theme ?

Can you attach your initrd?

Comment 9 Qian Cai 2010-05-14 05:05:06 UTC
> /usr/sbin/plymouth-set-default-theme ?
text

Comment 10 Qian Cai 2010-05-14 05:08:15 UTC
Created attachment 413944 [details]
initramfs

Comment 11 Ray Strode [halfline] 2010-05-14 14:47:44 UTC
Turns out my fix wasn't in plymouth-0.8.1-3.el6 after all..fixed package building now...

*** This bug has been marked as a duplicate of bug 590774 ***

Comment 12 Qian Cai 2010-05-22 15:48:56 UTC
Created attachment 415872 [details]
initramfs

Still have the same problem here using plymouth-0.8.3-3.el6.x86_64 + 2.6.32-28.el6 kernel.

Comment 13 Qian Cai 2010-05-22 19:40:25 UTC
After fully updated the system, it went away.


Note You need to log in before you can comment on or make changes to this bug.