Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591378 - fails with cannot run /bin/sh ./config.sub
Summary: fails with cannot run /bin/sh ./config.sub
Alias: None
Product: RHQ Project
Classification: Other
Component: No Component
Version: 1.3.1
Hardware: All
OS: Linux
high vote
Target Milestone: ---
: ---
Assignee: Heiko W. Rupp
QA Contact: Corey Welton
Depends On:
Blocks: jon-sprint11-bugs
TreeView+ depends on / blocked
Reported: 2010-05-12 04:40 UTC by Larry O'Leary
Modified: 2018-10-27 16:10 UTC (History)
2 users (show)

Fixed In Version: 2.4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2010-08-12 16:53:10 UTC

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated
Red Hat Bugzilla 535264 None None None Never
Red Hat Bugzilla 567843 None None None Never

Internal Links: 535264 567843 613685

Description Larry O'Leary 2010-05-12 04:40:39 UTC
Description of problem:
Unable to build Apache SNMP Connector module from source provided with JON 2.3.1 on Fedora or SuSE Linux system due to an error configure spits out when attempting to execute config.sub in the snmp2.0 directory.  

It appears that this is because config.sub and config.guess are missing.  I was able to get around this issue by executing automake -a from the snmp2.0 directory to add the missing files.

I have only seen and tested this issue on SuSE Linux Enterprise 11 and Fedora 11.

Comment 1 Charles Crouch 2010-05-19 03:28:40 UTC
We should see whether this is an issue on RHEL, if not then I suspect just a doc update should be sufficient here.

Comment 2 Heiko W. Rupp 2010-06-18 09:12:46 UTC
RHEL 5.5 needs a bunch of (additional) packages installed

- httpd-devel
- libtool
- automake

but building the modules for apache 2.0 and 2.2 fails with missing includes ( -I options are not correctly set) and 1.3 fails with some other error. 

As we are delivering binary versions, compiling from source is perhaps not that important.

The docs at tell that automake is needed.

Comment 3 ezra di biase 2010-06-28 21:00:03 UTC
Hi to all,
anyone came to a solution?
I'm in a similar situation: Red Hat AS4, apache 2.0.52 and I need to compile because the binaries are linked to GLIBC_2.4 and on my system there is GLIBC_2.3.

Comment 4 Larry O'Leary 2010-06-28 21:17:05 UTC
Try the workaround mentioned in the description:

>   It appears that this is because config.sub and config.guess 
>   are missing.  I was able to get around this issue by executing 
>   automake -a from the snmp2.0 directory to add the missing 
>   files.

Basically, you will force automake to generate/add the missing files.

Comment 5 ezra di biase 2010-06-29 16:29:00 UTC
Hi all,
I solved following this post from RHQ Project:

It was a Solaris environment bug but I tried and it worked.

Comment 6 Heiko W. Rupp 2010-07-09 11:26:06 UTC
r10793 adds a switch for Solaris that defaults to the RHEL behaviour

Comment 7 Corey Welton 2010-07-12 15:05:49 UTC
Confirmed that running automake works.  After running it, I got:

[root@core-01 snmp2.0]# automake -a no proper invocation of AM_INIT_AUTOMAKE was found. You should verify that invokes AM_INIT_AUTOMAKE, that aclocal.m4 is present in the top-level directory, and that aclocal.m4 was recently regenerated (using aclocal). installing `./config.guess' installing `./config.sub'
automake: no `' found for any configure output

And then reattempting the build was successful.

However, per comment #1, do we need to have this documented somewhere?

Comment 8 Corey Welton 2010-07-12 15:07:04 UTC
Marking this verified.

Comment 9 Corey Welton 2010-08-12 16:53:10 UTC
Mass-closure of verified bugs against JON.

Note You need to log in before you can comment on or make changes to this bug.