Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591357 - RHEL6 info test: no --no-progressbar option for sosreport
Summary: RHEL6 info test: no --no-progressbar option for sosreport
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Qian Cai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-12 01:08 UTC by Greg Nichols
Modified: 2010-09-21 12:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
On Red Hat Enterprise Linux 6, the info test no longer runs sosreport with the "--no-progressbar" option.
Clone Of:
Environment:
Last Closed: 2010-09-20 12:14:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
info test patch to use --no-progressbar only on RHEL5 (deleted)
2010-05-12 01:17 UTC, Greg Nichols
no flags Details | Diff
info test patch using --help rather than keying on RHEL version (deleted)
2010-05-26 17:51 UTC, Greg Nichols
no flags Details | Diff
info test patch that retries sosreport if --no-progressbar fails (deleted)
2010-05-27 15:25 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0702 normal SHIPPED_LIVE v7 bug fix and enhancement update 2010-10-21 07:59:09 UTC

Description Greg Nichols 2010-05-12 01:08:58 UTC
Description of problem:

The --no-progressbar option was removed from sosreport on RHEL6, causing the info test to fail, and no sosreport is produced.

Version-Release number of selected component (if applicable):

v7 1.2 R1

Comment 1 Greg Nichols 2010-05-12 01:17:45 UTC
Created attachment 413301 [details]
info test patch to use --no-progressbar only on RHEL5

Comment 3 Rob Landry 2010-05-26 15:18:52 UTC
bad news is older versions of RHEL5 include a version of sysreport without this option.

Comment 4 Rob Landry 2010-05-26 15:23:13 UTC
At least RHEL5 GA, I'm not certain the log of when and where sysreport changes.

Comment 5 Greg Nichols 2010-05-26 16:35:02 UTC
You mean sosreport, not sysreport.

So we should remove --no-progressbar compeletely, and add this fix to the v7 1.1 errata as well.

Comment 6 Rob Landry 2010-05-26 16:59:06 UTC
yes sorry, old versions of sosreport do not support the --no-progress bar option; IIRC the reason that was put in was because the shift to sosreport causes long strings of gibberish in the logs so it's not a bad thing to have unfortunately it seems to come and go between versions of sosreport.

Comment 8 Greg Nichols 2010-05-26 17:51:11 UTC
Created attachment 416951 [details]
info test patch using --help rather than keying on RHEL version

Comment 9 Rob Landry 2010-05-27 13:59:56 UTC
is it worth it to go ahead and presume that at some point the --help will be wrong and v7 should try again if sysreport with --no-progress exits failed?

Comment 10 Greg Nichols 2010-05-27 15:25:35 UTC
Created attachment 417286 [details]
info test patch that retries sosreport if --no-progressbar fails

Comment 13 Caspar Zhang 2010-09-09 10:55:37 UTC
Confirmed that the bug has been fixed in >= v7 1.2  R3, move to 'VERIFIED'

Comment 16 errata-xmlrpc 2010-09-20 12:14:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0702.html

Comment 17 Jaromir Hradilek 2010-09-21 12:53:50 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
On Red Hat Enterprise Linux 6, the info test no longer runs sosreport with the "--no-progressbar" option.


Note You need to log in before you can comment on or make changes to this bug.