Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591276 - firstboot aborts trying to open display in text console.
Summary: firstboot aborts trying to open display in text console.
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firstboot
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Martin Gracik
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 19:23 UTC by Nick Dokos
Modified: 2013-07-04 12:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-11 21:24:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nick Dokos 2010-05-11 19:23:37 UTC
Description of problem:

firstboot seems to require a graphics display: on text consoles,
it aborts with the backtrace show below. This is on x86_64 (dl380
and dl785) but it's probably hardware-independent.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install RHEL6.0snap2 and specify "text console=XXX"
2. Watch the first boot.
3.
  
Actual results:
...
Traceback (most recent call last):
  File "/usr/sbin/firstboot", line 24, in <module>
    from meh.ui.gui import GraphicalIntf
  File "/usr/lib/python2.6/site-packages/meh/ui/gui.py", line 21, in <module>
    import gtk
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 64, in <module>
    _init()
  File "/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py", line 52, in _init
    _gtk.init_check()
RuntimeError: could not open display
		Welcome to Red Hat Enterprise Linux Server
		Press 'I' to enter interactive startup.
...

Expected results:
No error.

Additional info:

Comment 2 RHEL Product and Program Management 2010-05-11 20:31:21 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Bill Nottingham 2010-05-11 21:24:47 UTC

*** This bug has been marked as a duplicate of bug 585077 ***


Note You need to log in before you can comment on or make changes to this bug.