Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591251 - Dolphin Terminal issues garbage ^C command when changing directories
Summary: Dolphin Terminal issues garbage ^C command when changing directories
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 18:23 UTC by Peter Gückel
Modified: 2010-06-05 03:19 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-05 01:58:21 UTC


Attachments (Terms of Use)

Description Peter Gückel 2010-05-11 18:23:26 UTC
Description of problem:
With the Terminal Panel enabled, when changing directories by 
clicking in the graphical part of Dolphin, the Terminal will show 2 commands, 
on the first being ^C (control uppercase-C), then on a second line, the cd 
command.

Version-Release number of selected component (if applicable):
4.4.3-2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
As formerly, clicking inthe graphical part of dolphin to change directories should issue only one corresponding command in the Terminal Panel, namely the cd command.

Additional info:

Comment 1 Peter Gückel 2010-05-29 05:15:14 UTC
This blemish is still present in kde-4.80.

Comment 2 Steven M. Parrish 2010-06-05 01:41:44 UTC
This is a issue which needs to be reported upstream.  Please file a report at
http://bugs.kde.org  

Please add upstream report info to this report.  We will monitor the upstream
report for a resolution.

Thanks for the report



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Kevin Kofler 2010-06-05 01:58:21 UTC
Actually, as I explained on the mailing list when this came up, this is not a bug at all, it's a bugfix: it makes sure the entry line is clear when the cd command is entered, otherwise, if e.g. the user has typed "rm -rf " before changing the directory, a disaster is bound to happen!

Comment 4 Kevin Kofler 2010-06-05 03:19:42 UTC
In fact, this is the commit which changed this:
http://websvn.kde.org/?view=revision&revision=1106403
and this is the bug it fixed:
https://bugs.kde.org/show_bug.cgi?id=161637


Note You need to log in before you can comment on or make changes to this bug.