Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591206 - liveinst fails - anaconda quits - networkmanager crashes
Summary: liveinst fails - anaconda quits - networkmanager crashes
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 16:27 UTC by Grant Williamson
Modified: 2010-05-12 05:55 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-0.8.1-0.1.git20100510.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-11 22:41:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Grant Williamson 2010-05-11 16:27:38 UTC
Description of problem:
Trying to install el6 snapshot 2 from livedvd to disk.


Version-Release number of selected component (if applicable):
RHEL6.0-20100428.3
anaconda-13.12.32-1
NetworkManager-0.8.0-6.git20100408

How reproducible:
Create live dvd of el6.
Boot livedvd, login.
Run liveinst as user.
NetworkManager dies.
Anaconda crashes.

[liveuser@localhost ~]$ liveinst 
umount: /media/*: not found
  No volume groups found
18:15:44 Starting graphical installation.
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 977, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 301, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 64, in reset
    self.network = network.Network()
  File "/usr/lib/anaconda/network.py", line 276, in __init__
    devhash = isys.getDeviceProperties(dev=None)
  File "/usr/lib/anaconda/isys.py", line 382, in getDeviceProperties
    nm = bus.get_object(NM_SERVICE, NM_MANAGER_PATH)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.NetworkManager was not provided by any .service files

This looks like a similar issue I saw a few weeks ago on Fedora 13.

Comment 2 Chris Lumens 2010-05-11 17:03:10 UTC
anaconda requires NM to be running, so the fix for this is to make sure NM doesn't crash.

Comment 3 Grant Williamson 2010-05-11 17:41:25 UTC
Interesting install NetworkManager-0.8.0-13.git20100509.fc12.i686.rpm from F12 testing updates and the installer actually starts, NM no longer crashes.

Comment 4 RHEL Product and Program Management 2010-05-11 17:57:42 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Dan Williams 2010-05-11 22:41:56 UTC
(In reply to comment #3)
> Interesting install NetworkManager-0.8.0-13.git20100509.fc12.i686.rpm from F12
> testing updates and the installer actually starts, NM no longer crashes.    

There's been quite a few changes recently that could fix random crashes, so I'll mark this as fixed.  If you wouldn't mind trying a recent RHEL6 version just to confirm, please re-open if you still see the problem with the following builds:

http://people.redhat.com/dcbw/NetworkManager/RHEL-6/

thanks!

Comment 6 John Walicki 2010-05-12 02:15:51 UTC
Dan - Thanks for the fix.  IBM will test tomorrow.

Comment 7 Grant Williamson 2010-05-12 05:55:19 UTC
Will wait till next snapshot. Does not run on snapshot 2.

[liveuser@localhost ~]$ liveinst 
umount: /media/*: not found
  0 logical volume(s) in volume group "VolGroup" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 603, in <module>
    import signal, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.py", line 25, in <module>
    import _isys
ImportError: /usr/lib/libnm-util.so.1: undefined symbol: g_malloc0_n


Note You need to log in before you can comment on or make changes to this bug.