Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 591125 - System clock uses UTC checkbox not retained
Summary: System clock uses UTC checkbox not retained
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 13:48 UTC by Kamil Páral
Modified: 2010-06-15 16:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-15 16:18:11 UTC


Attachments (Terms of Use)
bug demonstration video (deleted)
2010-05-11 13:48 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2010-05-11 13:48:01 UTC
Created attachment 413146 [details]
bug demonstration video

Description of problem:
When I unselect "System clock uses UTC" checkbox, hit Forward and then Back, the checkbox is again checked. See attached video.

Version-Release number of selected component (if applicable):
anaconda-13.41

How reproducible:
always

Comment 1 Brian Lane 2010-06-02 00:37:47 UTC
Fixed for rawhide with commit 1fc2308662c4391728eb6cde6ead31bafd6300f7

Comment 2 Brian Lane 2010-06-11 15:48:36 UTC
Ales reports that the call to hasWindows is happening too early, before storage is initialized so this needs a different solution. See https://www.redhat.com/archives/anaconda-devel-list/2010-June/msg00158.html

Comment 3 Brian Lane 2010-06-15 16:18:11 UTC
I cannot reproduce this on current rawhide after reverting the commit. Closing it for now.


Note You need to log in before you can comment on or make changes to this bug.