Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590965 - Can not boot up guest after modprobe vhost_net then remove it
Summary: Can not boot up guest after modprobe vhost_net then remove it
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-11 05:38 UTC by Qunfang Zhang
Modified: 2010-06-30 04:59 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-11 05:52:47 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Qunfang Zhang 2010-05-11 05:38:04 UTC
Description of problem:
vhost_net module is not loaded by default and we can boot up a guest successfully.
But, after modprobe it (still can boot up guest at this moment) and then remove it, the guest can not boot up with the following message:

warning: could not open /dev/net/tun: no virtual network emulation
qemu-kvm: -net tap,vlan=0,script=/etc/qemu-ifup,ifname=hello: Device 'tap' could not be initialized

Command line:
# /usr/libexec/qemu-kvm -m 2G -smp 2 -rtc-td-hack -usbdevice tablet -no-kvm-pit-reinjection  -drive file=win2k8-r2.qcow2,media=disk,if=ide,cache=off,werror=stop,rerror=stop -net nic,vlan=0,macaddr=1e:2d:0a:18:9f:4d,model=e1000 -net tap,vlan=0,script=/etc/qemu-ifup,ifname=hello -vnc :10 -monitor stdio -boot c -cpu qemu64,+sse2 -uuid b1428152-97b8-4bd3-a24c-16c91177fa31 -startdate now -balloon none -name 161


Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.51.el6.x86_64
kernel: 2.6.32-24.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Boot a guest with the above command line.
2.Add the vhost_net module.
#modprobe  vhost_net
#lsmod | grep vhost_net
3.Boot the guest again.
4.Remove the vhost_net module.
#modprobe -r vhost_net
#lsmod | grep vhost_net
5.Boot the guest again with the same command line.
  
Actual results:
After step 5, guest can not boot up.

warning: could not open /dev/net/tun: no virtual network emulation

Expected results:
Guest can boot up successfully all the time.

Additional info:

Comment 1 Qunfang Zhang 2010-05-11 05:52:47 UTC
Sorry, I used "modprobe -r" that removed the "tun" module.  So, this is not a bug and I will close it.


Note You need to log in before you can comment on or make changes to this bug.