Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590891 - Connecting to web gui
Summary: Connecting to web gui
Keywords:
Status: CLOSED DUPLICATE of bug 646258
Alias: None
Product: freeIPA
Classification: Retired
Component: Documentation
Version: 2.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: David O'Brien
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
: 635919 (view as bug list)
Depends On:
Blocks: 646258
TreeView+ depends on / blocked
 
Reported: 2010-05-10 21:37 UTC by Shawn
Modified: 2015-01-04 23:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 646258 (view as bug list)
Environment:
Last Closed: 2011-01-14 03:29:08 UTC


Attachments (Terms of Use)

Description Shawn 2010-05-10 21:37:42 UTC
Hello:

Description of problem:

The Administration Guide shows how to use the web interface to perform certain functions. However it never gives any indication of what to put in the address bar in order to reach the web interface in the first place.

Link to the documentation in question. Section 3.

http://freeipa.org/docs/2.0.0/Administration_Guide/en-US/html/

Lookin at bug 430191 it looks like the the web interface should only ever be used from the server you are trying to configure. Is that so? You shouldn't change the default address it listens to? What is the point of the web interface then?

Comment 1 Rob Crittenden 2010-09-27 19:06:36 UTC
*** Bug 635919 has been marked as a duplicate of this bug. ***

Comment 2 Rob Crittenden 2010-09-28 17:11:50 UTC
Just wanted to add a little bit more information to this.

By default IPA is set up to redirect requests to the root of the web server to:
 - The correct hostname (so http://test/ to http://test.example.com)
 - The SSL version (https://test.example.com)
 - and finally to https://test.example.com/ipa/ui

/ipa/ui is where the IPA GUI lives.

In IPA v1 TurboGears was the UI and you reached if via mod_proxy through Apache which is why TurboGears only listened on localhost. We need Apache to perform the kerberos auth for us. In IPA v2 TurboGears was dropped and the UI runs within Apache itself now.

Comment 3 David O'Brien 2011-01-14 03:29:08 UTC

*** This bug has been marked as a duplicate of bug 646258 ***


Note You need to log in before you can comment on or make changes to this bug.