Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590732 - DELL T310 with PERC H200 hangs during install; BMC reported multiple fatal PCI bus errors
Summary: DELL T310 with PERC H200 hangs during install; BMC reported multiple fatal PC...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: x86_64
OS: Linux
low
urgent
Target Milestone: rc
: ---
Assignee: Shyam Iyer
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 15:12 UTC by Dave
Modified: 2015-04-28 04:18 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-19 16:54:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dave 2010-05-10 15:12:09 UTC
Description of problem:

DELL T310 with PERC H200 hangs during x66_64 install; BMC reported multiple fatal PCI bus errors on H200 (PCI slot 1).

XEON 3450, 8GB ECC UDIMM, PERC H200 and hotswap backplane w/2 SATA HDD RAID 1. Additionally, an internal SATA HDD connected to port A in ATA mode (NOT raid).  Current release firmware as of 5/6/2010.

Version-Release number of selected component (if applicable):
April Beta.

How reproducible:

Steps to Reproduce:
1. Install on system with PERC H200 array (unusual: AND on-board SATA HDD A)
2. Observe installation hangs about half way through
3. Observe multiple fatal PCI bus errors reported at iDRAC LCD display panel

Actual results:


Expected results:


Additional info:
This system installs and runs RHEL 5.5 beta w/o issue

Comment 2 RHEL Product and Program Management 2010-05-10 16:54:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Dave 2010-05-11 00:43:24 UTC
Additional and NEW troubleshooting information.  It is possible there are two problems - 1) PCIe bus errors and 2) installer hang.

Installed on both H200 attached disks and (NEW) on-board SATA port.  Both installs locked up about 2/3 into package list.  PCIe bus errors did not occur when installing to on-board SATA port.

All installer defaults, basic storage, replace existing install.  Selected only the target disk for the install, did not select any other disks to be mounted.

1) The install did in fact progress past occurence of the PCIe bus errors.  I didn't notice that before.  Bus errors are displayed on diagnostic panel by BMC iDRAC BMC right after disk init, just before hostname dialog.

Install proceeds to packages where it hangs at about package #450, about 2/3 of package list.  The screen turns blank with exception of underline cursor in top left and arrow cursor where it was before screen blanked.  Mouse cannot move mouse cursor.

BMC (iDRAC 6) SEL log reports two errors repeated three times:  PCIe fatal bus error sensor for slot 1 (H200 slot), and PCIe fata bus error Bus 0 device % function 0 (presumably also the H200).

Installed onto H200 two different times and disks (1.6GB and 160MB) both non-raid single disk connected to H200, with on-board SATA ports disabled in BIOS.  Same results both times.


2) NEW: Installed to disk connected to on-board SATA port.  PCIe bus errors DID NOT occur.  Install hung at about the SAME e place, around package 400-450.

Comment 4 Raghavendra Biligiri 2010-06-11 09:02:07 UTC
Dave, 

Based on your comments looks like the installation image being used might be corrupted (package installation fails while installing on H200 and on-board SATA. Can please check your installation image ?

Please share the system BIOS version, H200 controller firmware version and the BMC firmware version as well.

Comment 5 Dave 2010-06-16 02:40:47 UTC
Verified install media.  Also verified iso using sha checksum.

BIOS Information	
Manufacturer		Dell Inc.	
Version		1.2.1	
Release Date		01/28/2010	

Firmware Information	
Name		iDRAC6	
Version		1.30	
	
H200 Firmware Version	07.01.24.00

Comment 6 Raghavendra Biligiri 2010-07-10 10:02:11 UTC
Dave,

Can you please confirm if this issue is reproducible with latest RHEL6 build ?
I tried with RHEL6-Beta2 on a T310 with H200 controller but was not able to reproduce this issue.

Comment 7 RHEL Product and Program Management 2010-07-15 14:21:20 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 8 Dave 2010-07-15 14:30:33 UTC
Pci bus errors do not occur with beta 2.

However, system locks up when anaconda starts before first GUI appears.  Should I enter a new bug report against beta 2?

Installer not launching the gui is definitely a blocker for me since RHEL 5 installs fne on my system.

Comment 9 Raghavendra Biligiri 2010-08-03 04:51:32 UTC
(In reply to comment #8)
> Pci bus errors do not occur with beta 2.
> 
Ok, good. Then I guess you can close this issue.

> However, system locks up when anaconda starts before first GUI appears.  Should
> I enter a new bug report against beta 2?
> 
Yes, since this new behavior sounds completely different than the issue reported on this BZ, please file a new issue.

> Installer not launching the gui is definitely a blocker for me since RHEL 5
> installs fne on my system.

Comment 10 Shyam Iyer 2010-08-19 16:54:01 UTC
Closing based on Comment #8


Note You need to log in before you can comment on or make changes to this bug.