Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590700 - No dictionaries?
Summary: No dictionaries?
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: aspell
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ivana Varekova
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
: 713220 724017 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 14:08 UTC by Paul Howarth
Modified: 2015-05-20 13:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-11 09:50:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1223431 None None None Never

Internal Links: 1211039 1223431

Description Paul Howarth 2010-05-10 14:08:35 UTC
EL-6 beta includes aspell but not the separate language packages with the dictionaries. Is aspell any use without the dictionaries? Without even aspell-en, I'll need to build that myself to build any package that (for instance) uses aspell in its test suite.

Comment 2 RHEL Product and Program Management 2010-05-10 15:40:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Ivana Varekova 2010-05-11 09:50:31 UTC
aspell is the build requirance for several packages.

Comment 4 Paul Howarth 2010-05-11 09:59:58 UTC
I appreciate that but my question is: what use is the aspell support in these packages if there are no dictionaries to check against?

Comment 5 Bill Nottingham 2010-05-11 16:32:19 UTC
aspell is only included as a build requirement for hunspell dictionaries. All apps in RHEL use hunspell as their supported spell checker; it's recommended that other apps do the same wherever possible.

Comment 6 Paul Howarth 2010-06-24 13:57:39 UTC
One of my packages in EPEL is perl-Text-SpellChecker, which is built on perl-Text-Aspell, the perl binding for aspell. It needs the English dictionary for its test suite, as do most of the perl modules that use it.

I wondered if it would be possible to patch it to use hunspell instead and the obvious way to do that would have been to use Text::Hunspell (the official perl binding of hunspell, http://search.cpan.org/~eleonora/text_hunspell_1.3/) instead of Text::Aspell. Unfortunately Text::Hunspell doesn't actually work, segfaulting as soon as you actually try to use it (https://rt.cpan.org/Public/Bug/Display.html?id=39824). I contacted the maintainer of Text::Hunspell, who said:

  "I spent 3 full days with that problem, and the best result
   I got is the crash you write about."

  "I have no idea, how to get that fixed; I assume, some modification
   in hunspell caused the perl interface to break."

  "I am really sorry for this."

  "Best, eleonora"

The simplest option would seem to me to be to add aspell-en in EPEL-6 to resolve this. I am prepared to look after this if the Fedora maintainer doesn't want it.

Or does anyone have a better suggestion?

Comment 7 Paul Howarth 2010-09-22 21:05:36 UTC
Update: perl-Text-Hunspell has a new maintainer who has made it work with recent releases. It's packaged and built in Fedora, and branched for EPEL-6.

Also, perl-Text-SpellChecker now has support for a hunspell backend (via perl-Text-Hunspell) as an alternative to aspell.

Only sticking point ... RHEL-6 Server Beta 2 refresh seems to contain hunspell dictionaries for just about every language on the planet - except English(!), which is only available in RHEL-6 Workstation at the moment. Is this intended? Surely not? I need this package to build (and use) perl-Text-Hunspell in EPEL-6 and of course users of OpenOffice.org on RHEL-6 Server will most likely want it too...

Should I open a separate bug for this?

Comment 8 Ivana Varekova 2010-09-23 07:40:06 UTC
Please create a new bug report to this issue.

Comment 9 Paul Howarth 2010-09-23 08:07:31 UTC
Raised as Bug #636763, thanks.

Comment 10 Ivana Varekova 2011-06-15 03:38:29 UTC
*** Bug 713220 has been marked as a duplicate of this bug. ***

Comment 11 Jay Berkenbilt 2011-06-15 15:13:35 UTC
I'd also point out that emacs's flyspell-mode uses aspell by default, though it can be configured to use hunspell.

Comment 12 Bill Nottingham 2011-06-15 18:48:09 UTC
Jay - can you file that as a new bug against emacs? We should just configure it to use hunspell out of the box.

Comment 13 Jay Berkenbilt 2011-06-15 21:02:14 UTC
Done -- see bug 713600.

Comment 14 Peter Schiffer 2011-11-02 13:26:29 UTC
*** Bug 724017 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.