Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590696 - Add support for fence-virt to connect directly to libvirt ESX or vSphere/VirtualCenter server
Summary: Add support for fence-virt to connect directly to libvirt ESX or vSphere/Virt...
Keywords:
Status: CLOSED DUPLICATE of bug 624673
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-virt
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Lon Hohberger
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 595378 (view as bug list)
Depends On: 595380 610811
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 13:59 UTC by Perry Myers
Modified: 2011-04-29 01:48 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 590697 (view as bug list)
Environment:
Last Closed: 2010-11-27 13:33:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Perry Myers 2010-05-10 13:59:52 UTC
Description of problem:
fence_vmware uses a proprietary perl API that is not in RHEL.  But the libvirt client in RHEL6 supports URIs to connect to both ESX and VirtualCenter/vSphere mgmt servers.

We should be able to point fence_virt on a virtual cluster node to point to the vSphere/VirtualCenter server for all other guests so that it can just ask the mgmt server to do the fencing for it.

This does not affect fence_virtd at all since in ESX deployments we have no host access so there will be no fence_virtd running.

This may also require backporting fence_virt or a similar agent to RHEL5 to support the RHEL5 use case.

Comment 1 Perry Myers 2010-07-02 13:47:39 UTC
*** Bug 595378 has been marked as a duplicate of this bug. ***

Comment 2 Perry Myers 2010-11-27 13:33:09 UTC
Instead of integrating into fence-virt, fence_vmware will be reworked to use the SOAP API exposed by VMware.  Marking as duplicate of bug # 624673

*** This bug has been marked as a duplicate of bug 624673 ***


Note You need to log in before you can comment on or make changes to this bug.