Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590644 - CGI.pm popup_menu produces invalid HTML
Summary: CGI.pm popup_menu produces invalid HTML
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl
Version: 5.5
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Marcela Mašláňová
QA Contact: Petr Šplíchal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 12:03 UTC by Martin Poole
Modified: 2018-11-27 21:55 UTC (History)
4 users (show)

Fixed In Version: perl-5.8.8-38.el5
Doc Type: Bug Fix
Doc Text:
Cause The popup_menu call will generate invalid HTML. Consequence Invalid HTML is lacking a space. Fix Regular expression was fixed. Result Correct HTML with spaces on correct places.
Clone Of:
Environment:
Last Closed: 2012-02-21 05:39:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to fix that matches upstream change. (deleted)
2010-05-10 12:03 UTC, Martin Poole
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0199 normal SHIPPED_LIVE perl bug fix update 2012-02-20 14:54:01 UTC

Description Martin Poole 2010-05-10 12:03:05 UTC
Created attachment 412808 [details]
patch to fix that matches upstream change.

Description of problem:

the popup_menu call generate invalid HTML lacking a space

Version-Release number of selected component (if applicable):

perl-5.8.8-27.el5

How reproducible:

Always

Steps to Reproduce:

perl -MCGI -e 'print CGI::popup_menu(-name=>"test", -class=>"class_name", -values => ["one", '"two"], -attributes=> { one => { -title => "the_title"} } ),"\n";' 
  
Actual results:

<select name="test"  class="class_name">
<option  title="the_title"value="one">one</option>
<option value="two">two</option>
</select>

Expected results:

<select name="test"  class="class_name">
<option title="the_title" value="one">one</option>
<option value="two">two</option>
</select>

Additional info:

Already fixed upstream.

Comment 3 RHEL Product and Program Management 2010-08-09 19:50:36 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Product and Program Management 2011-05-31 14:09:07 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 13 Marcela Mašláňová 2011-09-26 07:29:24 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    The popup_menu call will generate invalid HTML.
Consequence
    Invalid HTML is lacking a space.
Fix
    Regular expression was fixed.
Result
    Correct HTML with spaces on correct places.

Comment 17 errata-xmlrpc 2012-02-21 05:39:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0199.html


Note You need to log in before you can comment on or make changes to this bug.