Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590581 - PATCH: libiscsi get_firmware_foo does not work without first creating a libiscsi context
Summary: PATCH: libiscsi get_firmware_foo does not work without first creating a libis...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iscsi-initiator-utils
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Mike Christie
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-10 08:40 UTC by Hans de Goede
Modified: 2012-06-27 10:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 590580
Environment:
Last Closed: 2012-06-27 10:01:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Hans de Goede 2010-05-10 08:40:14 UTC
+++ This bug was initially created as a clone of Bug #590580 +++

Created an attachment (id=412756)
PATCH: call sysfs_init from libiscsi_get_firmware_foo

Hi Mike,

The libiscsi_get_firmware_foo functions do not work without first creating a libiscsi context, while they are intended to work without a context. The problem is that the sysfs code needs to be initialized before use and it is used by
the fwparam code. This patch fixes this by calling sysfs_init() when
libiscsi_get_firmware_foo is called and sysfs_init was not called yet.

I'll clone this bug for 5.5 as I believe we need it there too.

Thanks & Regards,

Hans

p.s.

I can add this to pkg CVS myself if you want, but I'm not sure if I have commit rights there, only one way to find out I guess :)


Note You need to log in before you can comment on or make changes to this bug.