Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590466 - Doesn't suspend on lid close
Summary: Doesn't suspend on lid close
Keywords:
Status: CLOSED DUPLICATE of bug 590090
Alias: None
Product: Fedora
Classification: Fedora
Component: upower
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 590521 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-09 17:15 UTC by Bastien Nocera
Modified: 2013-01-10 08:08 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-10 20:28:23 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2010-05-09 17:15:21 UTC
kernel-2.6.33.3-85.fc13.x86_64

$ sudo evtest /dev/input/event0 
Input driver version is 1.0.0
Input device ID: bus 0x19 vendor 0x0 product 0x5 version 0x0
Input device name: "Lid Switch"
Supported events:
  Event type 0 (Sync)
  Event type 5 (?)
    Event code 0 (?)
Testing ... (interrupt to exit)




Event: time 1273424988.764554, type 5 (?), code 0 (?), value 1
Event: time 1273424988.764572, -------------- Report Sync ------------
Event: time 1273424991.980589, type 5 (?), code 0 (?), value 0
Event: time 1273424991.980605, -------------- Report Sync ------------

This happens when closing and then opening the lid. And my system fails to suspend when I close the lid, as expected.

Comment 1 Adam Williamson 2010-05-10 12:20:15 UTC
For me this isn't a blocker, it doesn't hit anything on the criteria and it's not really a critical function. Though obviously it's an inconvenience and we should fix it ASAP, I'd  be happy with it going out as an update.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Adam Williamson 2010-05-10 12:40:46 UTC
*** Bug 590521 has been marked as a duplicate of this bug. ***

Comment 3 Adam Williamson 2010-05-10 12:41:28 UTC
The dupe bug 590521 has a hardware profile from one sufferer of this bug:

http://www.smolts.org/client/show/pub_efe3df8e-c410-4ae1-974b-4f8956e3a79e

Rodd, Bastien, can you please say what hardware you're using? Thanks.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 4 Adam Williamson 2010-05-10 12:58:52 UTC
FWIW, this system - a Thinkpad X40 - does *not* suffer the bug. Setting it to suspend on lid close, with kernel -85, it does try to suspend when the lid is closed.

Comment 5 Mihai Harpau 2010-05-10 13:04:45 UTC
On my laptop, Dell Latitude E5400, with F13 RC2 also I don't see this bug.

Comment 6 Bastien Nocera 2010-05-10 13:43:35 UTC
My machine is a Macbook Air first gen (MacbookAir1,1). It regressed from earlier kernels though I don't have them at hand to test anymore.

Comment 7 Adam Williamson 2010-05-10 14:32:17 UTC
Do you happen to remember which was the last kernel that worked? That'd help narrow it down.

Comment 8 Matthew Garrett 2010-05-10 14:53:54 UTC
There isn't supposed to be a keycode for the lid. It sends a switch event, which is event type 5, event code 0. The evtest output shows that correctly switching between state 0 and 1. So I think the kernel is fine here.

Comment 9 Adam Williamson 2010-05-10 15:12:18 UTC
on my working laptop, I get exactly the same (well, minus timestamps, obviously) evtest output, FWIW.

Comment 10 Adam Williamson 2010-05-10 15:18:41 UTC
jlaska agrees this is not a blocker, taking off the list. if anyone really disagrees, please add it again and we'll discuss at the go/no-go tomorrow.

Comment 11 Bastien Nocera 2010-05-10 19:18:52 UTC
Probably a upower bug:
TI:20:12:50	FI:up-input.c	FN:up_input_event_io,133
 - event.value=1 ; event.code=0 (0x00)
TI:20:12:50	FI:up-daemon.c	FN:up_daemon_set_lid_is_closed,686
 - lid_is_closed = no
TI:20:12:50	FI:up-input.c	FN:up_input_event_io,133
 - event.value=0 ; event.code=0 (0x00)
TI:20:12:50	FI:up-input.c	FN:up_input_event_io,137
 - not a switch event
TI:20:12:52	FI:up-input.c	FN:up_input_event_io,133
 - event.value=0 ; event.code=0 (0x00)
TI:20:12:52	FI:up-daemon.c	FN:up_daemon_set_lid_is_closed,686
 - lid_is_closed = yes
TI:20:12:52	FI:up-input.c	FN:up_input_event_io,133
 - event.value=0 ; event.code=0 (0x00)
TI:20:12:52	FI:up-input.c	FN:up_input_event_io,137
 - not a switch event

That's closing and reopening the lid.

And gnome-power-manager doesn't seem to receive events...

Comment 12 Bastien Nocera 2010-05-10 19:24:02 UTC
udev-151-9.fc13.x86_64
gnome-power-manager-2.30.1-1.fc13.x86_64

Comment 13 Bastien Nocera 2010-05-10 20:26:35 UTC
Regression from upower-0.9.12

upower 0.9.13 is broken.

Comment 14 Bastien Nocera 2010-05-10 20:28:23 UTC

*** This bug has been marked as a duplicate of bug 590090 ***


Note You need to log in before you can comment on or make changes to this bug.