Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590422 - Panic upon poweroff
Summary: Panic upon poweroff
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: John Feeney
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-09 13:38 UTC by Lubomir Rintel
Modified: 2013-01-10 07:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-17 18:45:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lubomir Rintel 2010-05-09 13:38:20 UTC
Description of problem:

A BUG_ON is triggered on poweroff.

Version-Release number of selected component (if applicable):

kernel-2.6.32-19.el6

Actual results:

poweroff -f
------------[ cut here ]------------
kernel BUG at kernel/time/clockevents.c:262!
invalid opcode: 0000 [#1] SMP 
last sysfs file: /sys/devices/pci0000:00/0000:00:1e.0/0000:01:0c.0/local_cpus
Modules linked in: p4_clockmod(U) ip6t_REJECT(U) nf_conntrack_ipv6(U) ip6table_filter(U) ip6_tables(U) ipv6(U) dm_mirror(U) dm_region_hash(U) dm_log(U) uinput(U) snd_intel8x0(U) snd_ac97_codec(U) ac97_bus(U) snd_seq(U) snd_seq_device(U) ppdev(U) snd_pcm(U) parport_pc(U) parport(U) iTCO_wdt(U) iTCO_vendor_support(U) snd_timer(U) ne2k_pci(U) dcdbas(U) sg(U) snd(U) e1000(U) 8390(U) serio_raw(U) soundcore(U) i2c_i801(U) snd_page_alloc(U) ext4(U) mbcache(U) jbd2(U) dm_snapshot(U) squashfs(U) vfat(U) fat(U) dm_multipath(U) sr_mod(U) sd_mod(U) cdrom(U) crc_t10dif(U) pata_acpi(U) ata_generic(U) ata_piix(U) i915(U) drm_kms_helper(U) usb_storage(U) drm(U) i2c_algo_bit(U) i2c_core(U) video(U) output(U) dm_mod(U) [last unloaded: scsi_wait_scan]

Pid: 1572, comm: poweroff Not tainted (2.6.32-19.el6.i686 #1) OptiPlex GX270               
EIP: 0060:[<c047ba07>] EFLAGS: 00010006 CPU: 0
EIP is at clockevents_notify+0xd7/0xe0
EAX: 00000003 EBX: c09db380 ECX: ffffffff EDX: 00000001
ESI: c09dd434 EDI: 00000282 EBP: c09dd400 ESP: f3f77dc8
 DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
Process poweroff (pid: 1572, ti=f3f76000 task=f3ea6a90 task.ti=f3f76000)
Stack:
 00000001 00000001 00000000 c0a1a934 fffffffa c0802ede 00000040 f707c000
<0> c0af0520 c0802e30 c04a94ed 00000001 c0a1a998 00000000 c0a1a934 fffffffa
<0> c080a2d6 00000017 00000001 00000010 00000001 00000000 c0a34188 c04734f7
Call Trace:
 [<c0802ede>] ? hrtimer_cpu_notify+0x8b/0x197
 [<c0802e30>] ? timer_cpu_notify+0x233/0x251
 [<c04a94ed>] ? rcu_adopt_orphan_cbs+0x1d/0x80
 [<c080a2d6>] ? notifier_call_chain+0x36/0x70
 [<c04734f7>] ? raw_notifier_call_chain+0x17/0x20
 [<c07f2609>] ? _cpu_down+0x109/0x290
 [<c044fa4f>] ? disable_nonboot_cpus+0xbf/0x130
 [<c0620fb5>] ? acpi_os_signal_semaphore+0x51/0x59
 [<c0644fb0>] ? acpi_ut_release_mutex+0x84/0x89
 [<c0467f3d>] ? kernel_power_off+0x1d/0x40
 [<c0468208>] ? sys_reboot+0x118/0x1d0
 [<c074f163>] ? sys_recvfrom+0xf3/0x160
 [<c05d757b>] ? radix_tree_delete+0x10b/0x240
 [<c0753e48>] ? skb_dequeue+0x48/0x70
 [<c05442ca>] ? fsnotify_clear_marks_by_inode+0x1a/0xb0
 [<c04a235c>] ? audit_syscall_entry+0x1fc/0x220
 [<c0513d34>] ? __fput+0x164/0x1f0
 [<c0413686>] ? syscall_trace_enter+0x146/0x1a0
 [<c040a4dc>] ? syscall_call+0x7/0xb
Code: c9 74 e1 8b 00 89 14 24 e8 b7 40 16 00 8b 14 24 83 f8 01 75 cf 8b 45 3c 85 c0 75 0f 89 f0 89 14 24 e8 8e 41 16 00 8b 14 24 eb b9 <0f> 0b eb fe 90 8d 74 26 00 57 56 53 8b 48 3c 89 c3 85 c9 75 73 
EIP: [<c047ba07>] clockevents_notify+0xd7/0xe0 SS:ESP 0068:f3f77dc8
---[ end trace a465ef1404d5542c ]---
Kernel panic - not syncing: Fatal exception
Pid: 1572, comm: poweroff Tainted: G      D    2.6.32-19.el6.i686 #1
Call Trace:
 [<c08055d5>] ? panic+0x42/0xed
 [<c0808bfc>] ? oops_end+0xbc/0xd0
 [<c040ba90>] ? do_invalid_op+0x0/0x90
 [<c040bb0f>] ? do_invalid_op+0x7f/0x90
 [<c047ba07>] ? clockevents_notify+0xd7/0xe0
 [<c08060ba>] ? schedule+0x88a/0xae0
 [<c04c54e9>] ? cpupri_set+0xb9/0x120
 [<c04101c8>] ? sched_clock+0x8/0x10
 [<c0474204>] ? sched_clock_local+0xa4/0x180
 [<c047bf6f>] ? tick_notify+0xcf/0x3a0
 [<c0807fcb>] ? error_code+0x73/0x78
 [<c047ba07>] ? clockevents_notify+0xd7/0xe0
 [<c0802ede>] ? hrtimer_cpu_notify+0x8b/0x197
 [<c0802e30>] ? timer_cpu_notify+0x233/0x251
 [<c04a94ed>] ? rcu_adopt_orphan_cbs+0x1d/0x80
 [<c080a2d6>] ? notifier_call_chain+0x36/0x70
 [<c04734f7>] ? raw_notifier_call_chain+0x17/0x20
 [<c07f2609>] ? _cpu_down+0x109/0x290
 [<c044fa4f>] ? disable_nonboot_cpus+0xbf/0x130
 [<c0620fb5>] ? acpi_os_signal_semaphore+0x51/0x59
 [<c0644fb0>] ? acpi_ut_release_mutex+0x84/0x89
 [<c0467f3d>] ? kernel_power_off+0x1d/0x40
 [<c0468208>] ? sys_reboot+0x118/0x1d0
 [<c074f163>] ? sys_recvfrom+0xf3/0x160
 [<c05d757b>] ? radix_tree_delete+0x10b/0x240
 [<c0753e48>] ? skb_dequeue+0x48/0x70
 [<c05442ca>] ? fsnotify_clear_marks_by_inode+0x1a/0xb0
 [<c04a235c>] ? audit_syscall_entry+0x1fc/0x220
 [<c0513d34>] ? __fput+0x164/0x1f0
 [<c0413686>] ? syscall_trace_enter+0x146/0x1a0
 [<c040a4dc>] ? syscall_call+0x7/0xb

Additional info:

This was apparently caused by a chceck added by stable-clockevents-Prevent-clockevent_devices-list-corruption-on-cpu-hotplug.patch

Comment 1 Lubomir Rintel 2010-05-09 13:39:01 UTC
A fix is already present in upstream tree, commit ea9d8e3f45404d411c00ae67b45cc35c58265bb7

Comment 3 RHEL Product and Program Management 2010-05-09 15:01:13 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Matthew Garrett 2010-05-17 18:45:48 UTC
ea9d8e3f45404d411c00ae67b45cc35c58265bb7 is present in our kernel as 0b2e8c102841b95607a30a558e345c651c6ce449.

*** This bug has been marked as a duplicate of bug 572438 ***


Note You need to log in before you can comment on or make changes to this bug.