Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590308 - SELinux is preventing /usr/bin/gnome-keyring-daemon "write" access on /tmp.
Summary: SELinux is preventing /usr/bin/gnome-keyring-daemon "write" access on /tmp.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 12
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:25488859670...
: 590306 590307 590309 590856 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-08 18:42 UTC by Reinhard
Modified: 2010-06-23 08:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-23 08:12:24 UTC


Attachments (Terms of Use)

Description Reinhard 2010-05-08 18:42:42 UTC
Zusammenfassung:

SELinux is preventing /usr/bin/gnome-keyring-daemon "write" access on /tmp.

Detaillierte Beschreibung:

[SELinux ist in freizügigem Modus. Dieser Zugriff wurde nicht verweigert.]

SELinux denied access requested by gnome-keyring-d. It is not expected that this
access is required by gnome-keyring-d and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Zugriff erlauben:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Zusätzliche Informationen:

Quellkontext                  unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023
Zielkontext                   system_u:object_r:tmp_t:s0
Zielobjekte                   /tmp [ dir ]
Quelle                        gnome-keyring-d
Quellpfad                     /usr/bin/gnome-keyring-daemon
Port                          <Unbekannt>
Host                          (removed)
RPM-Pakete der Quelle         gnome-keyring-2.28.2-2.fc12
RPM-Pakete des Ziels          filesystem-2.4.30-2.fc12
Richtlinien-RPM               selinux-policy-3.6.32-113.fc12
SELinux aktiviert             True
Richtlinientyp                targeted
Enforcing-Modus               Permissive
Plugin-Name                   catchall
Rechnername                   (removed)
Plattform                     Linux (removed)
                              2.6.32.11-99.fc12.x86_64 #1 SMP Mon Apr 5 19:59:38
                              UTC 2010 x86_64 x86_64
Anzahl der Alarme             3
Zuerst gesehen                Sa 08 Mai 2010 20:33:44 CEST
Zuletzt gesehen               Sa 08 Mai 2010 20:33:44 CEST
Lokale ID                     8b791643-c32d-4032-b03e-d361db7eb651
Zeilennummern                 

Raw-Audit-Meldungen           

node=(removed) type=AVC msg=audit(1273343624.901:25999): avc:  denied  { write } for  pid=2096 comm="gnome-keyring-d" name="tmp" dev=dm-3 ino=32641 scontext=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmp_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1273343624.901:25999): avc:  denied  { add_name } for  pid=2096 comm="gnome-keyring-d" name="keyring-WI9FJb" scontext=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmp_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1273343624.901:25999): avc:  denied  { create } for  pid=2096 comm="gnome-keyring-d" name="keyring-WI9FJb" scontext=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:tmp_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1273343624.901:25999): arch=c000003e syscall=83 success=yes exit=0 a0=13be250 a1=1c0 a2=13be262 a3=a0 items=0 ppid=1894 pid=2096 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=7 comm="gnome-keyring-d" exe="/usr/bin/gnome-keyring-daemon" subj=unconfined_u:system_r:abrt_helper_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gnome-keyring-d,abrt_helper_t,tmp_t,dir,write
audit2allow suggests:

#============= abrt_helper_t ==============
#!!!! The source type 'abrt_helper_t' can write to a 'dir' of the following type:
# abrt_var_cache_t

allow abrt_helper_t tmp_t:dir { write create add_name };

Comment 1 Miroslav Grepl 2010-05-10 11:24:02 UTC
*** Bug 590307 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2010-05-10 11:24:25 UTC
*** Bug 590306 has been marked as a duplicate of this bug. ***

Comment 3 Miroslav Grepl 2010-05-10 11:24:55 UTC
*** Bug 590309 has been marked as a duplicate of this bug. ***

Comment 4 Miroslav Grepl 2010-05-10 11:34:11 UTC
I think you have a labeling problem on your system. Could you try to execute

touch /.autorelabel; reboot

Comment 5 Miroslav Grepl 2010-05-11 08:07:47 UTC
*** Bug 590856 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.