Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590186 - Contrary to expectations IPv6 transparent proxy support is missing in RHEL 6 Beta.
Summary: Contrary to expectations IPv6 transparent proxy support is missing in RHEL 6 ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iptables
Version: 6.0
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: iptables-maint-list
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On: 591335
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 23:35 UTC by Kapil Dakhane
Modified: 2018-11-14 16:17 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: Result:
Clone Of:
Environment:
Last Closed: 2011-05-19 13:08:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0557 normal SHIPPED_LIVE iptables bug fix and enhancement update 2011-05-18 17:57:19 UTC

Description Kapil Dakhane 2010-05-07 23:35:23 UTC
Description of problem:
The IPv6 transparency has already been implemented and Bytemobile has verified that it works correctly. It is available at:
    http://git.balabit.hu/?p=bazsi/tproxy-2.6.git;a=summary
 
This was verified by running ip6tables command to set mangle rules:
 
ip6tables --table mangle --append PREROUTING --in-interface eth2.39 --protocol tcp --destination ::0/0 --destination-port 0:65535 --jump TPROXY --tproxy-mark 0x1/0xFFFFFFFF --on-ip fdfd:6b2a:f17e::c0a8:2701 --on-port 4101
This gives following output:
ip6tables v1.4.6: unknown option `--tproxy-mark'
Try `ip6tables -h' or 'ip6tables --help' for more information.
 
 
FYI, We require this feature to claim that our product is IPv6 compliant. 

Version-Release number of selected component (if applicable):
1.4.6

How reproducible:
Happens everytime.

Steps to Reproduce:
1. Setup an ipv6 address for an interface
2. Issue above mentioned command
3.
  
Actual results:

ip6tables v1.4.6: unknown option `--tproxy-mark'
Try `ip6tables -h' or 'ip6tables --help' for more information.

Expected results:
Command is accepted and IPv6 transparency works.

Additional info:
According to a reply on support Service Request # 2018648 :

07-MAY-2010 17:00:32 	Ruban, Ranjith
Hello

I was able to see RFE filed to add tproxy to rhel 6 but currently the rhel 6 beta does not seem to have support for (v6) tproxy and the option --tproxy-mark . Since rhel 6 beta is not a supported release would it be possible for you to file a bugzilla regarding this case.

Comment 2 RHEL Product and Program Management 2010-05-08 01:35:41 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Thomas Woerner 2010-05-10 08:59:08 UTC
Is this a bug for kernel or iptables? The git repo above is kernel related.

Comment 4 Kapil Dakhane 2010-05-10 20:18:38 UTC
Both, the kernel provides the support, and ip6tables provides the utility to use it.

Comment 5 Thomas Woerner 2010-05-11 07:24:41 UTC
According to the netfilter-devel mailing list, there is still work to do on the netfilter kernel modules. The code is not accepted upstream.

Please open an extra bugzilla entry for kernel and make this one depend on the kernel bug.

Thanks, Thomas

Comment 6 Kapil Dakhane 2010-05-11 22:36:14 UTC
I filed bug 591335 for the kernel.

Comment 8 Subhendu Ghosh 2010-07-28 20:09:05 UTC
Kernel BZ moved to RHEL 6.1 pending upstream inclusion

Comment 21 Florian Nadge 2011-02-03 11:53:50 UTC
Please be so kind and add a few key words to the Technical Note field of this
Bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks

Comment 22 Florian Nadge 2011-02-03 11:53:50 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:

Comment 27 errata-xmlrpc 2011-05-19 13:08:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0557.html


Note You need to log in before you can comment on or make changes to this bug.