Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590147 - quickly killing condor_configd results in an exception when service is already deleted
Summary: quickly killing condor_configd results in an exception when service is alread...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor-wallaby-client
Version: Development
Hardware: All
OS: Linux
low
low
Target Milestone: 1.3
: ---
Assignee: Robert Rati
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 20:29 UTC by Matthew Farrellee
Modified: 2010-10-21 18:45 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-21 18:45:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Matthew Farrellee 2010-05-07 20:29:41 UTC
Terminal one, start configd -

$ _CONDOR_QMF_BROKER_HOST=localhost _CONDOR_QMF_CONFIGD_LOG=configd.log ./condor_configd          
Traceback (most recent call last):
  File "./condor_configd", line 364, in ?
    sys.exit(main())
  File "./condor_configd", line 352, in main
    service.setup_timers()
NameError: global name 'service' is not defined

Terminal two, killall -v condor_configd -
 Notice exception in terminal one

From condor_configd -

      # Delay initial checkin after startup
      random.seed()
      time.sleep(random.randint(0, 10))
      service.setup_timers()

and

def exit_signal_handler(signum, frame):                                         
   global service, stop_running

   service.shutdown()
   del service
   logging.shutdown()
   stop_running = True

The exception above happens when the signal handler is called before the sleep returns. This could happen in any place where service is accessed after exit_signal_handler is registered, it is just most likely to happen at service.setup_timers()
If the signal handler is called before the sleep r

Comment 1 Robert Rati 2010-05-12 15:39:21 UTC
Made changes to configd to check whether the service has been deleted before acting upon it.  Have been unable to reproduce since the change.

Fixed in:
condor-wallaby-tools-2.7-1

Comment 2 Lubos Trilety 2010-08-18 08:01:20 UTC
Problem reproduced with (version):
condor-wallaby-client-2.6-0.5

Tested with (version):
condor-wallaby-client-3.4-1

Tested on:
RHEL5 x86_64,i386  - passed

>>> VERIFIED


Note You need to log in before you can comment on or make changes to this bug.