Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 590140 - Clicking Restart or Log out button in notification doesn't do anything
Summary: Clicking Restart or Log out button in notification doesn't do anything
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kpackagekit
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 546205 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-07 19:59 UTC by Martin Kho
Modified: 2010-09-29 06:14 UTC (History)
7 users (show)

Fixed In Version: kpackagekit 0.6.1-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-09-27 12:38:45 UTC


Attachments (Terms of Use)

Description Martin Kho 2010-05-07 19:59:55 UTC
Description of problem:
After an update Kpackagekit sometimes offers a logout or restart notification. Clicking the "Logout" or "Restart" button in that notification doesn't do anything. Btw. Actually, two notifications pop up: (1) before a transaction starts and (2) after it has finished.

Version-Release number of selected component (if applicable):
kpackagekit-0.6.0-2.fc13.x86_64.rpm
PackageKit-0.6.3-1.fc13.x86_64.rpm

How reproducible:
The restart notification appears when 'critical' updates (eg. kernel, glibc) are installed. This notification contains two button "Restart" and "Not Now". No now dismisses the notification. A log out notification looks the same.

Steps to Reproduce:
1. Wait until 'critical' update or update that needs a log out, is available
2. Install update
3. Press "Restart" or "Logout" button
  
Actual results:
Nothing happens

Expected results:
System reboots or logs user out

Additional info:

Comment 1 Kevin Kofler 2010-05-09 14:55:30 UTC
*** Bug 546205 has been marked as a duplicate of this bug. ***

Comment 2 Steven M. Parrish 2010-06-05 01:30:18 UTC
This is a issue which needs to be reported upstream.  Please file a report at
http://bugs.kde.org  

Please add upstream report info to this report.  We will monitor the upstream
report for a resolution.

Thanks for the report



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Martin Kho 2010-06-07 18:56:16 UTC
Hi,

Reported at bko: https://bugs.kde.org/show_bug.cgi?id=241042

Martin Kho

Comment 4 collura 2010-08-25 23:52:47 UTC
looks like almost there on your fix.


https://bugs.kde.org/show_bug.cgi?id=241042

"Comment #2 From  Daniel Nicoletti   2010-08-17 00:40:15
Thanks for the bug report, this is now fixed in (0.6.1):
http://websvn.kde.org/?view=revision&revision=1164146"

Comment 5 collura 2010-08-26 15:22:36 UTC
fyi, i think this bug should stand on its own 
because specifically was about the 'failing restart button' 
but for completeness note that the 'failing restart button' subject does 
have passing mentions in one of the other bugs:

https://bugzilla.redhat.com/show_bug.cgi?id=513755#c15


for completeness, the following reference the restart notification being too early:

https://bugzilla.redhat.com/show_bug.cgi?id=513755
https://bugzilla.redhat.com/show_bug.cgi?id=553356
https://bugzilla.redhat.com/show_bug.cgi?id=582079
https://bugzilla.redhat.com/show_bug.cgi?id=616915

ps: looking forward to the upstream fix moving downstream, thanks for reporting it :')

Comment 6 Martin Kho 2010-09-26 07:34:32 UTC
Hi,

Last night I had to reboot after an update, running kpackagekit 0.6.1-1. As expected the notification button was working. I think, kpackagekit is back again. 

Thanks for the really great work!

Martin Kho

P.S. This report can be closed.

Comment 7 collura 2010-09-29 06:14:50 UTC
i can also confirm that the restart button is working for me as well as of kpackagekit-0.6.1-1.fc13 (x86_64)


Note You need to log in before you can comment on or make changes to this bug.